HDU2473 Junk-Mail Filter 解题报告【并查集+虚父节点】

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.
We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:
a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.
b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.
Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0
Sample Output
Case #1: 3
Case #2: 2
解题报告
这道题的题意是讲,总共有n个点,支持m个操作,该操作分为两类,第一类是把两个点归于一个集合中,第二个操作时把一个点从他原先所在的集合剥离出来。最后输出m次操作过后总共有多少个集合。
对于第二种操作,由于我们不能够确定有没有节点的父亲指向他,如果我们把他剥离出来,很有可能会将这些不应该被剥离出来的节点一并取出来。
由此,我们需要用到虚父节点。什么是虚父节点呢?简单地说,就是把每一个点的父亲指向一个新开的空间,这就是指该节点编号往后数n个的那个节点。这样一来,进行正常的合并操作时,就不会有任何节点的父亲节点指向0~n-1的范围。也就不用担心上面描述的那种情况了。
代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1250000;
int father[2*N+5],flag[2*N+5];
int T,n,m,ans,id;
int find(int a){return father[a]==a?a:father[a]=find(father[a]);}
void del(int a){father[a]=id++;}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        memset(flag,0,sizeof(flag));
        id=n+n,ans=0;
        for(int i=0;i<=n-1;i++)father[i]=i+n;
        for(int i=n;i<=n+n+m-1;i++)father[i]=i;
        while(m--)
        {
            char s[5];
            scanf("%s",s);
            if(s[0]=='M')
            {
                int u,v;
                scanf("%d%d",&u,&v);
                u=find(u),v=find(v);
                if(u!=v)father[u]=v;
            }
            else
            {
                int a;
                scanf("%d",&a);
                del(a);
            }
        }
        for(int i=0;i<=n-1;i++)
        {
            int a=find(i);
            if(!flag[a])ans++,flag[a]=1;
        }
        printf("Case #%d: %d\n",++T,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值