动态规划_poj3624

动态规划的第二道题,到现在动态规划掌握的都不好,还得练,唉

链接:http://poj.org/problem?id=3624

相关资料:http://pan.baidu.com/s/1ntv7IPF

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23066 Accepted: 10376

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
01背包

就是说,有n件物品,和一个容量为m的背包,给定每个物品的重量与价值,求背包所能容纳的最大价值

刚开始看,也没思路,看了些资料好像有些头绪,代码还是不知道怎么写。

参考了这篇博文:http://www.2cto.com/kf/201304/205165.html

用bag表示背包,用bag【i】【v】表示前i件物品放入容量为v的背包可以获得的最大价值;

则状态转移方程:bag【i】【v】=Max{bag[i-1][v],bag[i-1][v-p[i].wight]+p[i].value};

这题开二维数组超内存,这是第二次超内存。

空间优化:等价于bag【v】=Max{bag【v】,bag【v-p[i].wight】+p[i].value}

AC代码:#include<stdio.h>
#include<string.h>
struct node
{
    int value,wight;
}p[3500];
int bag[12900];
int Max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,m,i,j;
    scanf("%d%d",&n,&m);
    for(i=0;i<n;i++)scanf("%d%d",&p[i].wight,&p[i].value);
    memset(bag,0,sizeof(bag));
    for(i=0;i<n;i++)
    {
        for(j=m;j>=p[i].wight;j--)
        {
            bag[j]=Max(bag[j],bag[j-p[i].wight]+p[i].value);
        }
    }
    printf("%d\n",bag[m]);
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值