1666:Candy Sharing Game
-
时间限制:
- 1000ms 内存限制:
- 65536kB
-
描述
-
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
输入
- The input may describe more than one game. For each game, the input begins with the number N of students,followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself. 输出
- For each game, output the number of rounds of the game followed by the amount of candy each child ends up with,both on one line. 样例输入
-
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
样例输出
-
15 14 17 22 4 8
用计算机模拟游戏的过程即可,对下标使用求余运算就可以实现循环数组:
#include <stdio.h>
int main()
{
int n; scanf("%d",&n);
int candys[100];
int temp [100];
while( n != 0)
{
/*input*/
for(int i=0; i<n; ++i)
{ scanf("%d",&candys[i]); }
/*calculate*/
/*judge if it is the end of the game*/
bool final = true;
int count = 0;
for(int i=0; i<n-1;++i)
{
if(candys[i]!=candys[i+1])
{
final = false;
break;
}
}
while(!final)
{
for(int i=0; i<n; ++i)
{
temp[i] = ( candys[ (i+1)%n ]>>1 )+
( candys[ i ]>>1 );
if(temp[i]&1==1)
{ temp[i]++; }
}
for(int i=0; i<n; ++i)
{ candys[i] = temp[i];}
/*update final*/
final = true;
for(int i=0; i<n-1;++i)
if(candys[i]!=candys[i+1])
{ final = false; break;}
/*update count*/
count++;
}
/*output*/
printf("%d %d\n",count,candys[0]);
scanf("%d",&n);
}
return 0;
}