分享糖果

                                                                                分享糖果

时间限制(普通/Java):3000MS/10000MS          运行内存限制:65536KByte
总提交:22            测试通过:22

描述

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

输入

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

输出

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

样例输入

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

样例输出

15 14
17 22
4 8
大致意思是每个人把自己的一半糖果分给自己左边的同学,一回合之后如果同学手上的糖果数是奇数,老师则给他一颗糖果。要求求出回合数与最后同学手上的糖果数。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int a[1000];
    int i,n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        int sum=0,t;
        while(1)
        {
            t=a[1];
            for(i=1; i<n; i++)
            {
                a[i]=(a[i]+a[i+1])/2;
            }
            a[i]=(t+a[i])/2;
            for(i=1; i<=n; i++)
            {
                if(a[i]%2!=0)
                    a[i]+=1;
            }
            sum++;
            for(i=1;i<=n;i++)
            {
                if(a[i]!=a[1])
                    break;
            }
            if(i>n)
                break;
        }
        printf("%d %d\n",sum,a[1]);
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值