hdu 1258 Sum It Up

Sum It Up

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 49   Accepted Submission(s) : 33
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
 
 
 
 
给出一些数字去凑给定的数字。
将数字从大到小排序,因为不考虑顺序。dfs的参数里面一次是当前指的数组里的位置,sum求和,py。因为要以加法的格式打印出来,所以要用到py将原数组里面的数赋予另一个数组。当sum=所给的数字打印时从0到py-1输出就可以了。
 
 
#include<iostream>
#include<cmath>
#include<algorithm>
#include<iomanip>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
int n,m;
int ans;
int a[11111];
int b[11111];
void dfs(int px,int s,int py)
{
    if(s>n)
    return ;
    if(s==n)
    {
        ans++;
        for(int i=0;i<py;i++)
        {
            if(i)
            cout<<"+"<<b[i];
            else cout<<b[i];
        }
        cout<<endl;
    }
    for(int j=px;j<m;j++)
    {
        b[py]=a[j];
        dfs(j+1,s+a[j],py+1);
        while(j+1<m&&a[j]==a[j+1])
        j++;
    }
}
int main()
{      
   while(cin>>n>>m)
   {
       if(n==0||m==0)break;
       int i,j,k;
       for(i=0;i<m;i++)
       cin>>a[i];
       ans=0;
cout<<"Sums of "<<n<<":"<<endl;
       dfs(0,0,0);


if(!ans)cout<<"NONE"<<endl;
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值