hdu 1501 Zipper

Zipper

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 96   Accepted Submission(s) : 42
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes

Data set 3: no

给3个字符串,问后面一个是不是用前二个穿插形成的,顺序不能变。这道题用dfs,思路很简单,如果是符合的,那么一定第三个里面的单词一定是前2个中的一个的,并且

是有序的,所以从3个字符串的第一个往最后搜索就可以了,如果能搜完,就认为是对的。

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char a1[222];
char a2[222];
char a[444];
int l,l1,l2;
bool ans;
int vis[222][222];
void dfs(int x,int y,int z)
{
    if(x==l1&&y==l2&&z==l)
    {
        ans=1;
        return ;
    }
    
    if(vis[x][y]) return ;
    vis[x][y]=1;
    if(a1[x]!=a[z]&&a2[y]!=a[z])
    return ;
    if(a1[x]==a[z])
    dfs(x+1,y,z+1);
    if(ans)return ;
    if(a2[y]==a[z])
    dfs(x,y+1,z+1);
    
}
int main(){
    int n;
    cin>>n;
    int js=1;
  while(n--)
  {
    cin>>a1>>a2>>a;
      l=strlen(a);
      l1=strlen(a1);ans=0;
      l2=strlen(a2);
      memset(vis,0,sizeof(vis));dfs(0,0,0);
      
      if(ans)cout<<"Data set "<<js<<": "<<"yes"<<endl;
      else cout<<"Data set "<<js<<": "<<"no"<<endl;
      js++;
  }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值