hdu 2604 Queuing

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5862    Accepted Submission(s): 2559


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10 6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 


是一道需要自己构造矩阵的题目,通过题目可以得到一个递推式,f[n]=f[n-1]+f[n-3]+f[n-4],根据这个递推式可以构造一个1X4的矩阵和4X4的矩阵相乘得到下一个1X4的矩阵,再用快速幂去算矩阵相乘的结果。



#include<iostream>
#include<cstring>
#include<iomanip>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<queue>
using namespace std;
struct js{
    int ma[33][33];
};        
int city,n,M;
js operator * (js a,js b)
{
    js c;
    int i,j,k;
    memset(c.ma,0,sizeof(c.ma));
    for(i=0;i<4;i++)
    for(j=0;j<4;j++)
    for(k=0;k<4;k++)
    {
        c.ma[j][k]+=a.ma[j][i] * b.ma[i][k];
        c.ma[j][k]=c.ma[j][k]%M;
    }
    return c;
}
js operator ^ (js a,int k)
{
    js c;
    for(int i=0;i<4;i++)
    for(int j=0;j<4;j++)
    {
        if(i==j)c.ma[i][j]=1;
        else c.ma[i][j]=0;
    }
    while(k)
    {
        if(k&1)c=c*a;
        a=a*a;
        k >>= 1;
    }
    return c;
}
int main(){
        while(cin>>n>>M)
        {
            js a;
            js ans;
            a.ma[0][0]=a.ma[0][2]=a.ma[0][3]=a.ma[1][0]=a.ma[2][1]=a.ma[3][2]=1;
            int i,j;
            for(i=0;i<4;i++)
            for(j=0;j<4;j++)
            {
                if(a.ma[i][j]==1)continue;
                a.ma[i][j]=0;
            }
            ans.ma[0][0]=9;
            ans.ma[1][0]=6;
            ans.ma[2][0]=4;
            ans.ma[3][0]=2;
            
            if(n>3)
            {   
                if(n==4){
                    cout<<9%M<<endl;
                    continue;
                }
                js ans1=a^(n-4);
                int ans2=0;
                for(int s=0;s<4;s++)
                ans2=(ans2+ans1.ma[0][s]*ans.ma[s][0])%M;
            cout<<ans2<<endl;
        }
            else if(n!=0)cout<<ans.ma[3-n+1][0]%M<<endl;
            else cout<<0%M<<endl;
        }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值