poj 1651 Multiplication Puzzle

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10559 Accepted: 6580

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion


给出一串数,n个,从2到n-1个数字中去拿,每次拿都能拿掉1个数字,代价是该数字与相邻的2个数字相乘的积,问最终的最小代价;

从长度为2开始更新最小答案,状态转移方程为dp[i][j]=min{dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*dp[j]}





#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int a[111],dp[111][111];
		int i,j,k,len;
		for(i=1;i<=n;i++)
		cin>>a[i];
	    memset(dp,0,sizeof(dp));
	    for(len=2;len<n;len++)
        {  
            for(i=2;i+len<=n+1;i++)  
            {  
                j=i+len-1;  
                dp[i][j]=100000000;  
                for(k=i;k<j;k++)
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);  
            }  
        }
		cout<<dp[2][n]<<endl;  
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值