九度OJ 1092:Fibonacci (递归)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1923

解决:1378

题目描述:

    The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55...} are defined by the recurrence: 
    F0=0 F1=1 Fn=Fn-1+Fn-2,n>=2 
    Write a program to calculate the Fibonacci Numbers.

输入:

    Each case contains a number n and you are expected to calculate Fn.(0<=n<=30) 。

输出:

   For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入:
1
样例输出:
1
来源:
2006年上海交通大学计算机研究生机试真题

思路:

用数组递归


代码:

#include <stdio.h>
 
int fib(int n)
{
    int a;
    if (n==0)
        a = 0;
    else if (n==1)
        a = 1;
    else
        a = fib(n-2) + fib(n-1);
    return a;
}
 
int main(void)
{
    int n;
 
    while (scanf("%d", &n) != EOF)
    {
        printf("%d\n", fib(n));
    }
 
    return 0;
}
/**************************************************************
    Problem: 1092
    User: liangrx06
    Language: C
    Result: Accepted
    Time:30 ms
    Memory:912 kb
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值