九度OJ 1136:Number Steps(步数) (基础题)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:691

解决:412

题目描述:

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

输入:

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

输出:

For each point in the input, write the number written at that point or write No Number if there is none.

样例输入:
3
4 2
6 6
3 4
样例输出:
6
12
No Number
来源:
2008年北京大学软件所计算机研究生机试真题

思路:

细节题,要分清各类情况。


代码:

#include <stdio.h>
 
int main(void)
{
    int n, i;
    int x, y;
 
    while (scanf("%d", &n) != EOF)
    {
        for(i=0; i<n; i++)
        {
            scanf("%d%d", &x, &y);
            if (x == y || x-y == 2)
            {
                if (x%2 == 0)
                    printf("%d\n", x+y);
                else
                    printf("%d\n", x+y-1);
            }
            else
                printf("No Number\n");
        }
    }
 
    return 0;
}
/**************************************************************
    Problem: 1136
    User: liangrx06
    Language: C
    Result: Accepted
    Time:20 ms
    Memory:912 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值