Step6.1.6 hdu1301 Jungle Roads(克鲁斯卡尔)

Step6.1.6 hdu1301 Jungle Roads

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3955    Accepted Submission(s): 2875

 

 

Problem Description

 

 

The Head Elder of the tropical island ofLagrishan has a problem. A burst of foreign aid money was spent on extra roadsbetween villages some years ago. But the jungle overtakes roads relentlessly,so the large road network is too expensive to maintain. The Council of Eldersmust choose to stop maintaining some roads. The map above on the left shows allthe roads in use now and the cost in aacms per month to maintain them. Ofcourse there needs to be some way to get between all the villages on maintainedroads, even if the route is not as short as before. The Chief Elder would liketo tell the Council of Elders what would be the smallest amount they couldspend in aacms per month to maintain roads that would connect all the villages.The villages are labeled A through I in the maps above. The map on the rightshows the roads that could be maintained most cheaply, for 216 aacms per month.Your task is to write a program that will solve such problems.

 

The input consists of one to 100 data sets,followed by a final line containing only 0. Each data set starts with a linecontaining only a number n, which is the number of villages, 1 < n < 27,and the villages are labeled with the first n letters of the alphabet,capitalized. Each data set is completed with n-1 lines that start with villagelabels in alphabetical order. There is no line for the last village. Each linefor a village starts with the village label followed by a number, k, of roadsfrom this village to villages with labels later in the alphabet. If k isgreater than 0, the line continues with data for each of the k roads. The datafor each road is the village label for the other end of the road followed bythe monthly maintenance cost in aacms for the road. Maintenance costs will bepositive integers less than 100. All data fields in the row are separated bysingle blanks. The road network will always allow travel between all thevillages. The network will never have more than 75 roads. No village will havemore than 15 roads going to other villages (before or after in the alphabet).In the sample input below, the first data set goes with the map above.

 

The output is one integer per line for eachdata set: the minimum cost in aacms per month to maintain a road system thatconnect all the villages. Caution: A brute force solution that examines everypossible set of roads will not finish within the one minute time limit.

 

 

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

 

 

Sample Output

216

30

 

 

Source

Mid-Central USA 2002

题解:

求最小生成树,克鲁斯卡尔算法,其中最后一个村庄不输入与那些村庄相连。

源代码:

#include <iostream>

#include <algorithm>

#include <string>

 

using namespace std;

struct Road

{

   intc1,c2,value;

}rd[1000];

int node[30];

void init()

{

   memset(node,-1,sizeof(node));

}

bool mycmp(const Road &x,const Road &y)

{

   if(x.value< y.value)

     returntrue;

   returnfalse;

}

int find_set(int x)

{

   if(node[x]== -1)

     returnx;

   returnnode[x] = find_set(node[x]);

}

bool merge(int x,int y)

{

   intr1 = find_set(x);

   intr2 = find_set(y);

   if(r1== r2)

     return0;

   if(r1< r2)

     node[r2] = r1;

   else

     node[r1] = r2;

   return1;

}

 

int main()

{

   intn;

   while(cin>> n && n)

   {

     init();

     intnum = 0;

     charch[20];

     intc1,c2,dis,m;

     for(int i = 0;i < n-1;i++)

     {

        scanf("%s%d",ch,&m);

        c1 = ch[0] - 'A'+1;

        for(int k = 0;k < m;k++)

        {

          scanf("%s%d",ch,&dis);

          c2 = ch[0] - 'A' + 1;

          rd[num].c1 = c1;

          rd[num].c2 = c2;

          rd[num++].value = dis;

        }

     }

     sort(rd,rd+num,mycmp);

     intsum = 0,count = 0;

     for(int i = 0;i < num;i++)

     {

        if(merge(rd[i].c1,rd[i].c2))

        {

          sum += rd[i].value;

          count++;

        }

        if(count== n-1)

          break;

     }

     printf("%d\n",sum);

   }

   return0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值