Jungle Roads(prime——最小生成树)

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30


题目大意:
Lagrishan的一个热带岛屿上的行政长官有一个问题要解决。他决定把几年前得到的外国援助资金用于修建村庄之间的道路。但是丛林比道路多太多了,使道路网络的维护太过于昂贵了。理事会必须选择停止维修一些道路。上述左侧图显示当前所有使用中的道路,以及现在每月的维护费用。当然,村庄之间必需有一些公路能够相通,即使路线并不像以前一样短。行政长官想告诉理事会怎样才使每月的花费最小,并且所维持的道路,将连接所有村庄。上面的地图标记了村庄A到I。图显示了每月能够维护道路的最小费用为216aacms。你的任务是编写一个程序,将解决这些问题。
输入:
输入包含的数据集个数在100以内,以0作为最后一行。每个数据集的第一行只包含一个表示村庄个数的数n,

1<n<27,并且这n个村庄是由大写字母表里的前n个字母表示。接下来的n- 1行是由字母表的前n-1个字母开头。最后一个村庄表示的字母不用输入。对于每一行,以每个村庄表示的字母开头,然后后面跟着一个数字,表示有多少条道路可以从这个村到后面字母表中的村庄。如果k是大于0,表示该行后面会表示k条道路的k个数据。每条道路的数据是由表示连接到另一端村庄的字母和每月维修该道路的花费组成。维修费用是正整数的并且小于100。该行的所有数据字段分隔单一空白。该公路网将始终连接所有的村庄。该公路网将永远不会超过75条道路。没有任何一个村庄会有超过15条的道路连接到其他村庄(之前或之后的字母)。
下面的示例输入中,其中第一个的数据集是与上面的地图一致的。
输出:
输出是每行一个整数,表示每个数据集中每月维持道路系统连接到所有村庄所花费的最低成本。


刚开始时,我用%c输入并用getchar()吃掉回车,但是不能Ac,最后改成%s,用数组储存才通过;如果用c++的cin输入应该没这个问题。

#include<stdio.h>
#include<string.h>
//定义一个无穷大的数用来表示不可直接相连的两结点的权值
#define MAX 0x3f3f3f3f
/*
N:结点的个数;二维邻接矩阵(map):记录任意两结点的权值;
  一维数组(visited):标记结点,判定是否访问过;
  一维数组(low):记录任意两点间的最小权值
*/
int N,map[30][30],visited[30],low[30];
//prim算法求最小生成树
int prim()
{
    int i,j,pos,min,cost=0;
    //将(visited)数组全部初始化为零,表示所有结点未访问过
    memset(visited,0,sizeof(visited));
    //标记起点并记录(起点可以是任意的,一般选择’1‘)
    visited[0]=1;
    pos=0;
    //初始化low数组
    for(i=0;i<N;i++)
    {
        low[i]=map[pos][i];
    }
    //再循环N-1次,将所有结点添加到生成树中
	for(i=1;i<N;i++)
	{
		min=MAX;
		//遍历所有结点,找到未访问结点中,权值最小的点,并记录
		for(j=0;j<N;j++)
		{
			if(visited[j]==0&&min>low[j])
			{
				min=low[j];
				pos=j;
			}
		}
		//每次找到最小权值进行累加
		cost+=min;
		//标记找到的结点
		visited[pos]=1;
		//更新权值数组low数组
		for(j=0;j<N;j++)
		{
			if(visited[j]==0&&low[j]>map[pos][j])
				low[j]=map[pos][j];
		}
	}
	return cost;
}
int main()
{
    int m,i,j,a,b,money;
    //储存输入的字符
    char str[3],str1[3];
    while(scanf("%d",&N)&&N!=0)
    {
        //初始化二维邻接矩阵即地图
        memset(map,MAX,sizeof(map));
        for(i=1;i<N;i++)
        {
            scanf("%s%d",str,&m);
            //将图表信息储存在二维邻接矩阵map中
            for(j=1;j<=m;j++)
            {
                scanf("%s%d",str1,&money);
                map[str[0]-'A'][str1[0]-'A']=map[str1[0]-'A'][str[0]-'A']=money;
            }
        }
        //prim的返回值就是最小生成树的最小权值
        printf("%d\n",prim());
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值