【PAT1062】 Talent and Virtue sort&qsort用法

1062. Talent and Virtue (25)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Li

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade
where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
题意根据分数要求,将人员分组并排序输出。

此题用C++的代码,会有两个case超时;故改用C语言是实现。顺便尝试了sort和qsort两个排序函数的用法。

代码:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

struct Person
{
	char id[9];
	int virtue;
	int talent;
	int sum;
};

int cmp(const void* A,const void* B)		//返回false(0),则不用对调,实现从大到小
{
	Person *aa = (Person*)A;
	Person *bb = (Person*)B;
	if(aa->sum == bb->sum)
	{
		if(aa->virtue == bb->virtue)
		{
			return strcmp(aa->id,bb->id);
		}else
			return (aa->virtue < bb->virtue);
	}else
		return (aa->sum < bb->sum);
}

bool sort_cmp(const Person& aa,const Person& bb)		//返回false对调,实现从大到小
{
	if(aa.sum == bb.sum)
	{
		if(aa.virtue == bb.virtue)
		{
			if(strcmp(aa.id,bb.id)>0)			//对于字符数组的比较,有不同
				return false;
			else return true;
		}else
			return (aa.virtue > bb.virtue);
	}else
		return (aa.sum > bb.sum);
}

int main()
{
   int n,l,h;
   scanf("%d %d %d",&n,&l,&h);
   //cin>>n>>l>>h;
   Person *p = new Person[n];
   int i;
   vector<Person> sage,nobleman,foolman,others;

   for(i=0;i<n;i++)
   {
	   scanf("%s %d %d",p[i].id,&p[i].virtue,&p[i].talent);
	   //cin>>p[i].id>>p[i].virtue>>p[i].talent;
	   p[i].sum = p[i].virtue+p[i].talent;

	   if(p[i].virtue<l || p[i].talent<l)continue;		//直接跳过都低的

	   if(p[i].virtue>=h && p[i].talent>=h)				//圣人
	   {
		   sage.push_back(p[i]);
	   }else if(p[i].virtue>=h && p[i].talent<h)		//君子
	   {
		   nobleman.push_back(p[i]);
	   }else if(p[i].virtue<h && p[i].talent<h && p[i].virtue>=p[i].talent)		//愚人
	   {
		   foolman.push_back(p[i]);
	   }else											//其他人
	   {
		   others.push_back(p[i]);
	   }
   }
   sort(sage.begin(),sage.end(),sort_cmp);
   sort(nobleman.begin(),nobleman.end(),sort_cmp);
   sort(foolman.begin(),foolman.end(),sort_cmp);
   sort(others.begin(),others.end(),sort_cmp);
   //qsort(& *sage.begin(),sage.size(),sizeof(Person),cmp);
   //qsort(& *nobleman.begin(),nobleman.size(),sizeof(Person),cmp);
   //qsort(& *foolman.begin(),foolman.size(),sizeof(Person),cmp);
   //qsort(& *others.begin(),others.size(),sizeof(Person),cmp);

   int m = sage.size() + nobleman.size() + foolman.size() + others.size();
   printf("%d\n",m);
   //cout<<m<<endl;
   for(i=0;i<sage.size();i++)
	   printf("%s %d %d\n",sage[i].id,sage[i].virtue,sage[i].talent);
	   //cout<<sage[i].id<<' '<<sage[i].virtue<<' '<<sage[i].talent<<endl;
   for(i=0;i<nobleman.size();i++)
	    printf("%s %d %d\n",nobleman[i].id,nobleman[i].virtue,nobleman[i].talent);
	   //cout<<nobleman[i].id<<' '<<nobleman[i].virtue<<' '<<nobleman[i].talent<<endl;
   for(i=0;i<foolman.size();i++)
	    printf("%s %d %d\n",foolman[i].id,foolman[i].virtue,foolman[i].talent);
	   //cout<<foolman[i].id<<' '<<foolman[i].virtue<<' '<<foolman[i].talent<<endl;
   for(i=0;i<others.size();i++)
	    printf("%s %d %d\n",others[i].id,others[i].virtue,others[i].talent);
	  // cout<<others[i].id<<' '<<others[i].virtue<<' '<<others[i].talent<<endl;
    system("PAUSE");
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值