Crossing River POJ1700

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7873 Accepted: 2879

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

题意:

        几个人过河,每次过两人一人回,速度由慢者决定。问过河所需最短时间。

分析:

       寻找过河最优策略的规律,对于n个人过河,按速度从小到大排列。有两种最优策略供选择:①最快和次快过去,最快回;最慢和次慢过去,次快回,t=s[1]+s[0]+s[n-1]+s[1]。②最快和最慢过去,最快回;最快和次快过去,最快回,t=s[n-1]+s[0]+s[n-2]+s[0]。选择两者中用时较少的一个策略执行。如此便将最慢和次慢送过河,对剩下n-2个人循环处理。注意当n=1、n=2、n=3时直接相加处理即可。

程序源代码如下:

	#include <iostream>
	#include <algorithm>
	using namespace std;
	
	int main()
	{
		freopen("in.txt","r",stdin);
		int speed[1000];
		
		int t,n,time;
		cin>>t;
		int i,j;
		for(i=0;i<t;i++)
		{
			cin>>n;
			memset(speed,0,sizeof(speed));
			for(j=0;j<n;j++)cin>>speed[j];
			sort(speed,speed+n);  //从小到大排序
			time=0;
			while(n>3)
			{
				if(speed[1]*2 > speed[0]+speed[n-2])
					time=time+speed[0]+speed[0]+speed[n-1]+speed[n-2];
				else time=time+speed[1]+speed[0]+speed[n-1]+speed[1];
				n=n-2;
			}
			if(n==3)
				time=time+speed[0]+speed[1]+speed[2];
			else if(n==2)
				time=time+speed[1];
			else if(n==1)
				time=time+speed[0];
			cout<<time<<endl;
		}
		return 0;
	}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值