poj 2796 单调栈

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10  6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5
题意:
这个序列的所有子序列都有一个值,这个值==(子序列中所有的和)*(子序列中最小值)
问值最大的子序列的值是多少
思路:枚举序列中的每一个数,让这个数作为最小值,然后找以这个数为最小值的序列(由于是序列的和*最小值,所以序列当然是越长越好)这里暴力找肯定tle了,所以我们运用单调栈来解决这个问题
单调栈能维护的恰好是以一个数为最小值(或者是最大值)的序列能延伸的最左端和最右端
 
 
ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
const int maxn=1e5+5;
using namespace std;
long long a[maxn],l[maxn],r[maxn];
long long sum[maxn];
int main()
{
    int n;
    while(cin>>n)
    {
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        stack<int> s;
        for(int i=1;i<=n;i++)
        {
            while(!s.empty()&&a[s.top()]>=a[i])
            s.pop();
            if(s.empty())
            l[i]=1;
            else
            l[i]=s.top()+1;
            s.push(i);
        }
        while(!s.empty())s.pop();
        for(int i=n;i>=1;i--)
        {
            while(!s.empty()&&a[s.top()]>=a[i])
            s.pop();
            if(s.empty())
            r[i]=n;
            else
            r[i]=s.top()-1;
            s.push(i);
        }
        long long ans=-1;
        long long x,y;
        for(int i=1;i<=n;i++)
        {
            if(a[i]*(sum[r[i]]-sum[l[i]-1])>ans)
            {
                ans=a[i]*(sum[r[i]]-sum[l[i]-1]);
                x=l[i];
                y=r[i];
            }
        }
        cout<<ans<<endl<<x<<" "<<y<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值