hdu5073 数学化简

Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present. 


To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass. 

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia. 

The moment of inertia I of a set of n stars can be calculated with the formula 


where w  i is the weight of star i, d  i is the distance form star i to the mass of center. 

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position.

Now, you are supposed to calculate the minimum moment of inertia after transportation.
Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases. 

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.
Output
For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
Sample Input
2
3 2
-1 0 1
4 2
-2 -1 1 2
Sample Output
0

0.5

题意:给你n个星星的位置,这n个星星我们就可以确定这个星系的质量中心,由于星星的体积可以忽略不计,所以多个星星可以放在同一位置,我们可以改变k个星星的位置,那么质量中心可能就会变了,如何改变使得最后的惯性最小(惯性公式已给出)

思路:首先我们肯定要把k次机会全部用上,并且我们最后留下的n-k个星星一定要是连续的,我们只要枚举起点就可以了

ans=(a[l]-k)^2+.....+(a[r]-k)^2

直接算的话tle,我们可以将完全平方公式展开就为

ans=(a[l]^2+....+a[r]^2)-2*x*(a[l]+...+a[r])+x*x

其中x=(a[l]+..+a[r])/(n-k)

这样的话我们只需要记录区间和和区间平方和

ac代码:

#include<iostream>
#include<math.h>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;

typedef long long ll;
int n,k;
double d[50005];
double sum1[50005],sum2[50005];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(int i=0; i<n; i++)
            scanf("%lf",&d[i]);
        sort(d,d+n);
        sum1[0]=d[0];
        sum2[0]=d[0]*d[0];
        for(int i=1; i<n; i++)
        {
            sum1[i]=sum1[i-1]+d[i];
            sum2[i]=sum2[i-1]+d[i]*d[i];
        }
        if(k>=n-1)
        {
            printf("0.000000000\n");
            continue;
        }
        double s1=sum2[n-k-1];
        double s2=sum1[n-k-1];
        double s3=s2/(n-k);
        double s=s1-2*s3*s2+s3*s3*(n-k);
        for(int i=1; i<=k; i++)
        {
            s1=sum2[i+n-k-1]-sum2[i-1];
            s2=sum1[i+n-k-1]-sum1[i-1];
            s3=s2/(n-k);
            // printf("%lf %lf %lf\n",s1,s2,s3);
            double x=s1-2*s3*s2+s3*s3*(n-k);
            s=min(s,x);
        }
        printf("%.9lf\n",s);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值