非常可乐 HDU - 1495

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3






分析:bfs加dp。  dp记录每一种状态,防止重复走。注意最后清空栈的方法。












#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
#include<iomanip>
using namespace std;
const int INF = 0x3f3f3f3f;
const int NINF = 0xc0c0c0c0;
typedef long long ll;
int n,m,s;
int start[3];
bool vis[105][105][105];
struct Pot{
    int p[3];
    int step;
};
queue<Pot> q;
void turn(Pot temp,int t1,int t2){                // pour cola from t1 to t2;
   
    int d = start[t2] - temp.p[t2]; 
    if(temp.p[t1] >= d){
        temp.p[t2] = start[t2];
        temp.p[t1] -= d;
    }
    else {
        temp.p[t2] += temp.p[t1];
        temp.p[t1] = 0;
    }
    if(vis[temp.p[0]][temp.p[1]][temp.p[2]] == 1) return;
    else vis[temp.p[0]][temp.p[1]][temp.p[2]] = 1;
    temp.step++;
    q.push(temp);
}
int bfs(){
    Pot beg;
    beg.p[0] = s;
    beg.p[1] = 0;
    beg.p[2] = 0;
    beg.step = 0;
    q.push(beg);
    while(!q.empty()){
        Pot temp = q.front();
        q.pop();
        int cnt = 0;
        if(temp.p[0] == s/2) cnt++;
        if(temp.p[1] == s/2) cnt++;
        if(temp.p[2] == s/2) cnt++;
        if(cnt == 1)return temp.step+1;
        else if(cnt == 2) return temp.step;
        
        if(temp.p[0] != 0){
            if(temp.p[1] != n){
                turn(temp,0,1);
            }
            if(temp.p[2] != m){
                turn(temp,0,2);
            }
        }
        if(temp.p[1] != 0){
            if(temp.p[0] != s){
                turn(temp,1,0);
            }
            if(temp.p[2] != m){
                turn(temp,1,2);
            }
        }
        if(temp.p[2] != 0){
            if(temp.p[0] != s){
                turn(temp,2,0);
            }
            if(temp.p[1] != n){
                turn(temp,2,1);
            }
        }
    }
    return -1;
}
int main()
{
    while(cin >> s >> n >> m){
        if(s == 0) break;
        memset(vis,0,sizeof(vis[0][0][0])*105*105*105);             //dp to record that whether the current staute is exited.
        start[0] = s;
        start[1] = n;
        start[2] = m;
        if(s & 1){
            cout << "NO" << endl;
            continue;
        }
        int ans = bfs();
        if(ans == -1) cout << "NO"<<endl;
        else cout << ans << endl;

        queue<Pot> empty;                                           // clear the queue.
        swap(q,empty);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值