Zjnu Stadium HDU - 3047 带权并查集

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite. 
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2). 
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R. 
Input
There are many test cases: 
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space. 
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space. 

Output
For every case: 
Output R, represents the number of incorrect request. 
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2

        
  
Hint
Hint:
(PS: the 5th and 10th requests are incorrect)


题意:n个观众标号1~n,坐在环形的观众席上,一个位置可以坐好几个人。 给出 a b x 即b在a的顺时针x距离处。  现在给出你m条信息,让你判断错误的有几条(和前面冲突的就算错)

分析:  就我目前的水平看来,并查集实际上是一种维护森林关系的这么一种结构,每一个森林中的每一棵树都可以通过“母树(根)” 找到对应的关系,合并时只要将母树合并即可,原本两个森林里的任意两棵树都可以通过新的母树找到对应的关系。

就本题而言,这里的关系无非是两棵树之间的距离,那么我们如何确定两颗树的距离呢? 就像我刚才说的,通过母树。 假设A到母树的距离为a,B到母树的距离为b(都是顺时针的距离)。 那么A到B的顺时针距离就是a-b。  

需要注意的是路径压缩的时候,容易错,想法是直接算出到母树的距离,但写法上要注意!具体看代码







代码:

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 50010;
int par[maxn],val[maxn];
int search(int a){
    if(a == par[a]) return a;
    int temp = par[a];
    par[a] = search(par[a]);            //wa在这里
    val[a] += val[temp];
    val[a] %= 300;
    return par[a] ;
}
void unite(int a,int b,int x){
    int ra = search(a);
    int rb = search(b);
    par[ra] = rb;
    val[ra] += (x+val[b]-val[a]+300);     //为了防止负数
    val[ra] %= 300;
}
bool same(int a,int b){
    return search(a) == search(b);
}
int main()
{
    int m,n;
    while(scanf("%d%d",&n,&m)!=EOF){
        int cnt = 0;
        for(int i=0;i<=n;i++){
            par[i] = i;
            val[i] = 0;
        }
        for(int i=0;i<m;i++){
            int a,b,x;
            scanf("%d%d%d",&a,&b,&x);
            if(same(a,b)){
                if((val[a]-val[b]+300)%300 != x){
                    cnt++;
                }
            }
            else{
                unite(a,b,x);
            }
        }
        printf("%d\n",cnt);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值