HRBUST1754 Minimum Scalar Product【序列处理】

Minimum Scalar Product
Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 394(62 users) Total Accepted: 140(59 users) Rating: Special Judge: No

Description
You are given two vectors v1=(x1,x2,…,xn) and v2=(y1,y2,…,yn). The scalar product of these vectors is a single number, calculated as x1y1+x2y2+…+xnyn.

Suppose you are allowed to permute the coordinates of each vector as you wish. Choose two permutations such that the scalar product of your two new vectors is the smallest possible, and output that minimum scalar product.

Input
There are multiple test cases.

For each test case, the first line contains integer number n. The next two lines contain n integers each (1<=n<=800), giving the coordinates of v1 and v2 respectively.

Process to the end of file.

Output
For each test case, output a line X, where X is the minimum scalar product of all permutations of the two given vectors.

Sample Input
3
1 3 -5
-2 4 1
5
1 2 3 4 5
1 0 1 0 1

Sample Output
-25
6

问题链接HRBUST1754 Minimum Scalar Product
问题简述:给定n和2组n个数,求sum=a[1]*b[1]+a[2]*b[2]+…+a[n]*b[n],使得sum最小。
问题分析:这是一道GCJ的题目。把数排序后sum=a[i]*bn-i,sum就是最小值。这个结论可以通过数学推导来证明是正确的。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HRBUST1754 Minimum Scalar Product */

#include <bits/stdc++.h>

using namespace std;

const int N = 800;
long long v1[N], v2[N];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        for(int i = 0; i < n; i++) scanf("%lld", &v1[i]);
        for(int i = 0; i < n; i++) scanf("%lld", &v2[i]);

        sort(v1, v1 + n);
        sort(v2, v2 + n);

        long long sum = 0;
        for(int i = 0; i < n; i++)
            sum += v1[i] * v2[n - 1 - i];

        printf("%lld\n", sum);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值