MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. Aftereach guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determine the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strong when i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.
Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.
Input
The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would normally be specified). The maximum value for N will be 1000.
Output
The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.
Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 00
Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)
Regionals 1995 >> North America - North Central NA
问题链接:UVA340 UVALive5448 Master-Mind Hints。
题意简述:
输入多组测试用例,每个用例第1个数为n,n=0时结束。后面有若干行,每行输入n个正整数(值范围为1到9),第1行是n个秘密数(需要猜测的数),第2行开始是猜测的n个数,若猜测的n个数全为0则结束进入下一个测试用例。
求的是,猜测的n个数有几个相同(位置和值与值都相同),有几个相关(值相同而位置不同)。
问题分析:
网上相同版本的使用暴力法的程序居多,大概出自一人之手。可是,编写程序是要用巧,哪能动不动就暴力。
程序说明:
编写程序需要考虑通用性,使用宏定义是值得推荐的一种做法。
程序中,使用数组digitcount_s[]和digitcount_i[]来统计各种值出现的次数,这使得计算结果变得简单。
AC的C语言程序如下:
/* UVA340 UVALive5448 Master-Mind Hints */
#include <stdio.h>
#include <memory.h>
#define MIN(a, b) (((a) > (b)) ? (b) : (a))
#define VALNUM 10
#define MAXN 1000
int secret[MAXN];
int guess[MAXN];
int main(void)
{
int caseno=1, n, i;
int strong, independent;
int digitcount_s[VALNUM], digitcount_i[VALNUM];
while(scanf("%d", &n) != EOF && n != 0) {
printf( "Game %d:\n", caseno++ );
memset(digitcount_s, 0, sizeof(digitcount_s));
for(i=0; i<n; i++) {
scanf( "%d", &secret[i] );
digitcount_s[secret[i]]++;
}
for(;;) {
int sum = 0;
strong = 0;
independent = 0;
memset(digitcount_i, 0, sizeof(digitcount_i));
for(i=0; i<n; i++) {
scanf( "%d", &guess[i] );
sum += guess[i];
if(guess[i] == secret[i])
strong++;
digitcount_i[guess[i]]++;
}
if(sum == 0)
break;
for(i=1; i<VALNUM; i++)
independent += MIN(digitcount_s[i], digitcount_i[i]);
printf(" (%d,%d)\n", strong, independent - strong);
}
}
return 0;
}