For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M.
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N, 1 ≤ N ≤ 100, 000.
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.
Sample Input
3
216
121
2005
Sample Output
198
0
1979
Regionals 2005 >> Asia - Seoul
问题链接:UVA1583 UVALive3355 Digit Generator。
问题简述:(略)
问题分析:
查表法最为合理,即使试探法可能性太多,而且求最小的生成元比较困难。
不打表估计时间上也会超时。
程序说明:
程序中,打表功能封装到函数maketable(),使得主函数变得简洁。另外,打表时需要注意数组下标溢出问题。还需要注意,求的是最小生成元。
AC通过的C语言程序如下:
/* UVA1583 UVALive3355 Digit Generator */
#include <stdio.h>
#include <memory.h>
#define MAXN 100000
int ans[MAXN+1];
void maketable(int max)
{
int i, digitsum, n;
memset(ans, 0, sizeof(ans));
for(i=1; i<max; i++) {
digitsum = n = i;
while(n > 0) {
digitsum += n % 10;
n /= 10;
}
if(digitsum <= max)
if(ans[digitsum] == 0)
ans[digitsum] = i;
}
}
int main(void)
{
maketable(MAXN);
int t, n;
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
printf("%d\n", ans[n]);
}
return 0;
}