UVA1585 UVALive3354 Score【水题】

  There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problemand an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself andits just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10thproblem is 3 that is obtained by itself and its two previous consecutive ‘O’s.

  Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”.

  You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of testcases T is given in the first line of the input. Each test case starts with a line containing a stringcomposed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spacesbetween ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is tocontain the score of the test case.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55

30


Regionals 2005 >> Asia - Seoul


问题链接UVA1585 UVALive3354 Score

问题简述:(略)

问题分析

  这个题是计算得分,得分规则有点像保龄球的得分规则,连续正确的次数越多分数越高。

程序说明

  程序逻辑都是套路。


AC的C语言程序如下:

/* UVA1585 UVALive3354 Score */

#include <stdio.h>

int main(void)
{
    int t, ans, count;
    char c;

    scanf("%d", &t);
    getchar();
    while(t--) {
        ans = 0;
        count = 0;
        while((c = getchar()) != '\n') {
            if(c == 'O') {
                count++;
                ans += count;
            } else if(c == 'X')
                count = 0;
        }

        printf("%d\n", ans);
    }

    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值