UVA10815 Andy's First Dictionary【set+字符串切割】

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

  You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.


Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the

road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when


问题链接UVA10815 Andy's First Dictionary

题意简述

  输入一个文本文件,从中提取出字典,重复的单词被去掉。

问题分析

  用C++语言编写程序,可以练习使用STL的功能。另外一点,C++编写程序效率会更高。使用STL容器类的set,可以方便地去重复,而且还会自动排序。

程序说明

  使用C语言的库函数strtok()来切割单词,并且用空格' '作为分隔符。这是一种简便的做法。

  另外一种切割字符串的方法是,使用STL的字符串流(sstream)实现。


AC的C++程序如下:

/* UVA10815 Andy's First Dictionary */

#include <iostream>
#include <cstring>
#include <set>

using namespace std;

#define MAXN 512

set<string> dict;

int main()
{
    char s[MAXN], delim[] = " ", *p;

    while(cin >> s) {
        p = s;
        while(*p) {
            if(isalpha(*p))
                *p = tolower(*p);
            else
                *p= ' ';
            p++;
        }

        p = strtok(s, delim);
        while(p) {
             dict.insert(p);
             p = strtok(NULL, delim);
        }
    }

    for(set<string>::iterator iter =dict.begin(); iter != dict.end(); iter++)
        cout << *iter << "\n";

    return 0;
}


  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值