UVA10976 Fractions Again?!【水题】

  It is easy to see that for every fraction in the form 1k(k > 0), we can always find two positive integers x and y, x ≥ y, such that:

      1/k=1/x+1/y

  Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k?

Input

  Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).

Output

  For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

Sample Input

2

12

Sample Output

2

1/2 = 1/6 + 1/3

1/2 = 1/4 + 1/4

8

1/12 = 1/156 + 1/13

1/12 = 1/84 + 1/14

1/12 = 1/60 + 1/15

1/12 = 1/48 + 1/16

1/12 = 1/36 + 1/18

1/12 = 1/30 + 1/20

1/12 = 1/28 + 1/21

1/12 = 1/24 + 1/24


问题链接UVA10976 Fractions Again?!

题意简述

  输入正整数k,求满足1/k=1/x+1/y并且x≥y的正整数对x和y。

问题分析

  先枚举y,因为x≥y,其范围小。其他要点如下:

  1.因为1/k=1/x+1/y且x>0,所以1/k>1/y,得y>k;

  2.x≥y,有1/x1/y,且1/k=1/x+1/y,所以1/k-1/y1/y,得y2k;

  3.这样只需要y在k+1到2k之间枚举试算即可;

  4.因为1/k=1/x+1/y,得x=ky/(y-k)。

程序说明

  枚举试算过程中,必须满足ky/(y-k)是整数,并且x≥y。由于还要统计满足条件的整数对有多少,并且还有先输出,所以使用了数组ansx[]和ansy[]。不使用数组的话,就需要算两遍,第1遍先统计数量,第2遍计算x和y。

题记

  即便是暴力枚举,也需要进行数学推导,尽可能减小枚举的范围。

AC的C语言程序如下:

/* UVA10976 Fractions Again?! */

#include <stdio.h>

#define MAXN 10000

int main(void)
{
    int k, x, y, end, sum, ansx[MAXN], ansy[MAXN];

    while(scanf("%d", &k) != EOF) {
        sum=0;

        end = 2 * k;
        for(y=k+1; y<=end; y++){
            if((y * k) % (y - k) == 0){
                x = (y * k) / (y - k);
                if(x >= y) {
                    ansx[sum] = x;
                    ansy[sum] = y;
                    sum++;
                }
            }
        }

        printf("%d\n",sum);
        for(x=0; x<sum; x++)
            printf("1/%d = 1/%d + 1/%d\n",k, ansx[x], ansy[x]);
    }

    return 0;
}


  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值