HDU1213 How Many Tables【并查集】

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36533    Accepted Submission(s): 18184


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
 
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
 
2 4
 

Author
Ignatius.L
 

Source


问题链接:HDU1213 How Many Tables

问题简述

  测试用例有T组。输入n和m,分别表示总人数和朋友对的数量。再输入m个数对s和d表示s和d是朋友。朋友以及间接朋友坐在同一张桌子上。计算需要几张桌子?

问题分析

  这是一个有关图的连通性问题,可以用并查集来解决。并查集中,连通的各个结点都会指向相同的根。

程序说明

  程序中,构建一个用并查集,使得相互连通的子图指向相同的根,最后数一下有几个相互连通的子图就可以了。

  程序不够简洁,又写了一个简洁版。


AC的C++语言程序(简洁版)如下:

/* HDU1213 How Many Tables */

#include <iostream>

using namespace std;

const int N = 1000;
int f[N + 1], cnt;

void UFInit(int n)
{
    for(int i = 1; i <=n; i++)
        f[i] = i;
    cnt = n;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

void Union(int a, int b)
{
    a = Find(a);
    b = Find(b);
    if (a != b) {
        f[a] = b;
        cnt--;
    }
}

int main()
{
    int t, n, m, src, dest;

    // 输入测试用例数量
    cin >> t;
    while(t--) {
        cin >> n >> m;

        // 初始化并查集
        UFInit(n);

        // 输入m个朋友关系,构建并查集
        while(m--) {
            cin >> src >> dest;

            Union(src, dest);
        }

        // 输出结果:桌子数量,即相互联通子图的数量
        cout << cnt << endl;
    }

    return 0;
}



AC的C++语言程序如下:

/* HDU1213 How Many Tables */

#include <iostream>
#include <vector>

using namespace std;

// 并查集类
class UF {
private:
    vector<int> v;
public:
    UF(int n) {
        for(int i=0; i<=n; i++)
            v.push_back(i);
    }

    int Find(int x) {
        for(;;) {
            if(v[x] != x)
                x = v[x];
            else
                return x;
        }
    }

    bool Union(int x, int y) {
        x = Find(x);
        y = Find(y);
        if(x == y)
            return false;
        else {
            v[x] = y;
            return true;
        }
    }
};

int main()
{
    int t, n, m, src, dest, count;

    // 输入测试用例数量
    cin >> t;
    while(t--) {
        cin >> n >> m;

        UF uf(n);

        // 输入m个朋友关系,构建并查集
        while(m--) {
            cin >> src >> dest;

            if(uf.Find(src) != uf.Find(dest))
                uf.Union(src, dest);
        }

        // 计算需要桌子的数量:即相互联通子图的数量
        count = 0;
        for(int i=1; i<=n; i++)
            if(uf.Find(i) == i)
                count++;

        // 输出结果
        cout << count << endl;
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值