UVALive3199 Specialized Four-Digit Numbers【进制】

Find and list numbers in decimal notation that have the property that the sum of its digits equals thesum of its digits when represented in hexadecimal (base 16) notation and also equals the sum of itsdigits when represented in duodecimal (base 12) notation.

  For example, the number 2991 has the sum of (decimal) digits 2 + 9 + 9 + 1 = 21. Since 2991 =1 ∗ 1728 + 8 ∗ 144 + 9 ∗ 12 + 3, its duodecimal representation is 189312, and these digits also sum upto 21. But in hexadecimal 2991 is BAF16, and 11 + 10 + 15 = 36, so 2991 should be rejected by yourprogram.

  The next number (2992), however, has digits that sum to 22 in all three representations (includingBB016), so 2992 should be on the listed output. (We don’t want decimal numbers with fewer than fourdigits — excluding leading zeroes — so that 2992 is the first correct answer.)

Input

  The input file will contain several possible cases. Each test case consists of a line containing a pair ofpositive integers, separated by a space.

  Input will terminate with ‘0 0’ in a line byself. This line should not be processed.

Output

  For each input case, your output is to be all the numbers between the couple of integers (both included),that satisfy the requirements (in strictly increasing order), each on a separate line with no leading ortrailing blanks, ending with a new-line character.

  Separate the output for consecutive cases by a single blank line.

Sample Input

2900 3000

0 0

Sample Output

2992

2993

2994

2995

2996

2997

2998

2999


Regionals 2004 >> North America - Pacific Northwest


问题链接UVALive3199 Specialized Four-Digit Numbers

问题分析:四位数的10进制数字之和,12进制数字之和,16进制数字之和都相同的输出。需要注意的是输入数据格式和输出数据格式。

程序说明:(略)

题记:(略)


参考链接:(略)


AC的C语言程序如下:

/* UVALive3199 Specialized Four-Digit Numbers */

#include <stdio.h>

int sum_digits(int n, int base)
{
    int sum = 0;

    while(n) {
        sum += n % base;
        n /= base;
    }

    return sum;
}

int main(void)
{
    int start, end, d10, flag, i;

    flag = 0;
    while(~scanf("%d%d", &start, &end) && (start || end)) {
        if(flag)
            printf("\n");
        flag = 1;
        for(i=start; i<=end; i++) {
            d10 = sum_digits(i, 10);
            if(sum_digits(i, 12) == d10 && sum_digits(i, 16) == d10)
                printf("%d\n", i);
        }
    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值