UVA10783 Odd Sum【数列】

Given a range [a, b], you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range [3, 9] is 3 + 5 + 7 + 9 = 24.

Input

There can be at multiple test cases. The first line of input gives you the number of test cases, T (1 ≤ T ≤ 100). Then T test cases follow. Each test case consists of 2 integers a and b (0 ≤ a ≤ b ≤ 100) in two separate lines.

Output

For each test case you are to print one line of output – the serial number of the test case followed by the summation of the odd integers in the range [a, b].

Sample Input

2

1

5

3

5

Sample Output

Case 1: 9

Case 2: 8


问题链接UVA10783 Odd Sum

问题简述:(略)

问题分析

  数列区间求和问题。

  根据公式:1+3+...+2k-1 = k^2,进行计算。

程序说明

  需要考虑输入的a和b非奇数的情形,适当计算调整一下。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVA10783 Odd Sum */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t, a, b;

    scanf("%d", &t);
    for(int i=1; i<=t; i++) {
        scanf("%d%d", &a, &b);

        a /= 2;
        b = (b + 1) / 2;

        printf("Case %d: %d\n", i, b * b - a * a);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值