POJ2646 ZOJ1847 UVA10137 The Trip【数学】

509 篇文章 6 订阅
232 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3446 Accepted: 1055

Description

A number of students are members of a club that travels annually to exotic locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, and Atlanta. This spring they are planning a trip to Eindhoven.  
The group agrees in advance to share expenses equally, but it is not practical to have them share every expense as it occurs. So individuals in the group pay for particular things, like meals, hotels, taxi rides, plane tickets, etc. After the trip, each student's expenses are tallied and money is exchanged so that the net cost to each is the same, to within one cent. In the past, this money exchange has been tedious and time consuming. Your job is to compute, from a list of expenses, the minimum amount of money that must change hands in order to equalize (within a cent) all the students' costs.  

Input

Standard input will contain the information for several trips. The information for each trip consists of a line containing a positive integer, n, the number of students on the trip, followed by n lines of input, each containing the amount, in dollars and cents, spent by a student. There are no more than 1000 students and no student spent more than $10,000.00. A single line containing 0 follows the information for the last trip.

Output

For each trip, output a line stating the total amount of money, in dollars and cents, that must be exchanged to equalize the students' costs.

Sample Input

3
10.00
20.00
30.00
4
15.00
15.01
3.00
3.01
0

Sample Output

$10.00
$11.99

Source


问题链接POJ2646 ZOJ1847 UVA10137 The Trip

问题简述

  有n个学生,已经知道他们各自花费了多少,求平摊花费时,他们最少移动的钱是多少,精确到1美分。

问题分析(略)

程序说明

  计算时需要注意精度。

  先算出花费总额后,就可以算出平均花费。再算一下即可。

  要尽量避免排序!

题记:(略)

参考链接:(略)


AC的C++语言程序如下:


/* POJ2646 ZOJ1847 UVA10137 The Trip */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 1000;
double a[N], sum, ave, ans1, ans2;

int main()
{
    int n;

    while(~scanf("%d", &n) && n) {
        sum = 0;

        for(int i=0; i<n; i++) {
            scanf("%lf", &a[i]);
            sum += a[i];
        }

        ave = ((int)((sum / n + 0.005) * 100)) / 100.0;
        ans1 = ans2 = 0;
        for(int i=0; i<n; i++)
            if(a[i] > ave)
                ans1 += a[i] - ave;
            else
                ans2 += ave - a[i];

        printf("$%.2f\n", min(ans1, ans2));
    }

    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值