UVA10110 Light, more light【数学】

There is man named ”mabu” for switching on-off light in our University. He switches on-off the lightsin a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on.Another press will turn it off. To save power consumption (or may be he is mad or something else)he does a peculiar thing. If in a corridor there is n bulbs, he walks along the corridor back and forthn times and in i-th walk he toggles only the switches whose serial is divisable by i. He does not pressany switch when coming back to his initial position. A i-th walk is defined as going down the corridor(while doing the peculiar thing) and coming back again. Now you have to determine what is the finalcondition of the last bulb. Is it on or off?

Input

The input will be an integer indicating the n’th bulb in a corridor. Which is less then or equals 2^32 −1. A zero indicates the end of input. You should not process this input.

Output

Output ‘yes’ if the light is on otherwise ‘no’, in a single line.

Sample Input

3624181910

Sample Output

no

yes

no


问题链接UVA10110 Light, more light

问题简述:(略)

问题分析

  一个数学问题。

  因为只有完全方数的因子是奇数个,当输入数为完全平方数才能使灯开着。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVA10110 Light, more light */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    long long n, m;
    while(scanf("%lld", &n) && n) {
            m = (long long)sqrt(n);

            printf("%s\n", m * m == n ? "yes" : "no");
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值