UVA10110 Light, more light【数学】

There is man named ”mabu” for switching on-off light in our University. He switches on-off the lightsin a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on.Another press will turn it off. To save power consumption (or may be he is mad or something else)he does a peculiar thing. If in a corridor there is n bulbs, he walks along the corridor back and forthn times and in i-th walk he toggles only the switches whose serial is divisable by i. He does not pressany switch when coming back to his initial position. A i-th walk is defined as going down the corridor(while doing the peculiar thing) and coming back again. Now you have to determine what is the finalcondition of the last bulb. Is it on or off?

Input

The input will be an integer indicating the n’th bulb in a corridor. Which is less then or equals 2^32 −1. A zero indicates the end of input. You should not process this input.

Output

Output ‘yes’ if the light is on otherwise ‘no’, in a single line.

Sample Input

3624181910

Sample Output

no

yes

no


问题链接UVA10110 Light, more light

问题简述:(略)

问题分析

  一个数学问题。

  因为只有完全方数的因子是奇数个,当输入数为完全平方数才能使灯开着。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVA10110 Light, more light */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    long long n, m;
    while(scanf("%lld", &n) && n) {
            m = (long long)sqrt(n);

            printf("%s\n", m * m == n ? "yes" : "no");
    }

    return 0;
}




基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值