POJ3134 UVA1374 UVALive3621 ZOJ2824 Power Calculus【IDA*】

509 篇文章 9 订阅
281 篇文章 4 订阅
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2249 Accepted: 1231

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × xx3 = x2 × xx4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × xx3 = x2 × xx6 = x3 × x3x7 = x6 × xx14 = x7 × x7x15 = x14 × xx30 = x15 × x15x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2x8 = x4 × x4x8 = x4 × x4x10 = x8 × x2x20 = x10 × x10x30 = x20 × x10x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x × xx4 = x2 × x2x8 = x4 × x4x16 = x8 × x8x32 = x16 × x16x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12

Source


问题链接POJ3134 UVA1374 UVALive3621 ZOJ2824 Power Calculus

问题简述:(略)

问题分析

  使用IDA*算法实现。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ3134 UVA1374 UVALive3621 ZOJ2824 Power Calculus */

#include<iostream>

using namespace std;

const int N = 1000;
int n, ans, now[N + 1];

bool idax(int dep)
{
    if(dep > ans)
        return false;
    if((now[dep] << (ans - dep)) < n) // 剪枝
        return false;
    if(now[dep] == n)
        return true;

    for(int i=0; i<=dep; i++) {
        now[dep + 1] = now[dep] + now[i];
        if (idax(dep + 1))
            return true;
        now[dep + 1] = now[dep] - now[i];
        if (idax(dep + 1))
            return true;
    }

    return false;
}

int main()
{
    now[0] = 1;

    while(cin>>n && n) {
        ans = 0;
        while(!idax(0))
            ans++;
        cout << ans << endl;
    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值