UVA11636 Hello World!【模拟】

When you first made the computer to print the sentence “Hello World!”, you felt so happy, not knowing how complex and interesting the world of programming and algorithm will turn out to be. Then you did not know anything about loops, so to print 7 lines of “Hello World!”, you just had to copy and paste some lines. If you were intelligent enough, you could make a code that prints “Hello World!” 7 times, using just 3 paste commands. Note that we are not interested about the number of copy commands required. A simple program that prints “Hello World!” is shown in Figure 1. By copying the single print statement and pasting it we get a program that prints two “Hello World!” lines. Then copying these two print statements and pasting them, we get a program that prints four “Hello World!” lines. Then copying three of these four statements and pasting them we can get a program that prints seven “Hello World!” lines (Figure 4). So three pastes commands are needed in total and Of course you are not allowed to delete any line after pasting. Given the number of “Hello World!” lines you need to print, you will have to find out the minimum number of pastes required to make that program from the origin program shown in Figure 1.


Input

The input file can contain up to 2000 lines of inputs. Each line contains an integer N (0 < N < 10001) that denotes the number of “Hello World!” lines are required to be printed.

  Input is terminated by a line containing a negative integer.

Output

For each line of input except the last one, produce one line of output of the form ‘Case X: Y ’ where X is the serial of output and Y denotes the minimum number of paste commands required to make a program that prints N lines of “Hello World!”.

Sample Input

2

10

-1

Sample Output

Case 1: 1

Case 2: 4


问题链接UVA11636 Hello World!

问题简述

  开始的时候只有1行,对于输入的n,问需要几次拷贝就能把1行拷贝成n行。

问题分析

  一次一次模拟就好。

  如果把所有都拷贝下来则拷贝速度最快,有点像贪心法,实际应该是模拟。

程序说明:(略)

题记

  不会做就枚举,再不会做就模拟。

参考链接:(略)


AC的C++语言程序如下:

/* UVA11636 Hello World! */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n, caseno = 0;

    while(~scanf("%d", &n) && n > 0) {
        int cnt = 1, ans  = 0;

        while(cnt < n) {
            ans++;
            cnt <<= 1;
        }

        printf("Case %d: %d\n", ++caseno, ans);
    }

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值