UVA11582 Colossal Fibonacci Numbers!【快速模幂+数列模除】

The i'th Fibonacci number f(i) is recursively defined in the following way:

    • f(0) = 0 and f(1) = 1

    • f(i + 2) = f(i + 1) + f(i) forevery i ≥ 0

  Your task is to compute some values of this sequence.

Input

Input begins with an integer t ≤ 10, 000, the number of test cases. Each test case consists of three integers a, b, n where 0 ≤ a, b < 2^64 (a and b will not both be zero) and1 ≤ n ≤ 1000.

Output

For each test case, output a single line containing the remainder of f(ab) upon division by n.

Sample Input

3

1 1 2

2 3 1000

18446744073709551615 18446744073709551615 1000

Sample Output

1

21

250

 

 

问题链接UVA11582 Colossal Fibonacci Numbers!

问题简述:(略)

问题分析

  Fibonacci数列各项进行模除后,必然从某项开始出现循环。利用这个循环,数列就不用无限计算下去了。

程序说明:(略)

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

/* UVA11582 Colossal Fibonacci Numbers! */

#include <bits/stdc++.h>

//#define DEBUG

using namespace std;

typedef unsigned long long ULL;

const int N = 1000;
int fib[N * N];

// 快速模幂
ULL powmod(ULL x, ULL n, ULL m)
{
    ULL result = 1;
    for(; n; n>>=1) {
        if(n & 1) {
            result *= x;
            result %= m;
        }
        x *= x;
        x %= m;
    }

    return result;
}

int main()
{
    int t;

    scanf("%d", &t);
    while(t--) {
        ULL a, b;
        int n, M = 2;

        scanf("%llu%llu%d", &a, &b, &n);
        // 计算数列到出现循环为止(模除n)
        fib[0] = 0;
        fib[1] = 1 % n;
        for(int i=2; i<=n * n; i++) {
            fib[i] = (fib[i - 2] + fib[i - 1]) % n;
            if(fib[i - 2] == 1 && fib[i - 1] == 0) {
                M = i - 1;
#ifdef DEBUG
                printf("M=%d\n", M);
#endif
                break;
            }
        }

        int k = powmod(a % M, b, M);
        printf("%d\n", fib[k]);
    }

    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值