POJ1435 ZOJ1390 UVA1607 UVALive2440 Gates【二分】

509 篇文章 6 订阅
281 篇文章 4 订阅

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 283 Accepted: 133 Special Judge

Description

In contemporary VLSI chip industry, the software tools used by electrical engineers perform many optimizations. Your task is to implement one specific optimization of some chip design. Your tool is given an acyclic net of NAND gates (NAND gate computes the negated conjunction of its inputs, i.e. the output value of the gate is 0 if and only if its both input values are 1). The net is a part of already synthesized component and cannot be changed. All the inputs of the net are connected to one signal x. The objective is to disconnect x from some inputs and to assign constant signals 0 and/or 1 to those inputs in such a way that the function implemented by the design remains unchanged.  

We say that an assignment of x's and/or 0's and/or 1's to the inputs of the net is optimal if the number of inputs connected to x is the smallest possible but the net still computes the same function as if all the inputs were connected to x.  


Example  

Look at the following design.  



We can change it to the design with only one variable input, for example:  



(Observe that there are other ways of connecting the inputs to just one x and to some number of 0's and 1's that implement the same function).  


Task  

Write a program which for each data set:  

reads the description of the net,  

computes an optimal assignment of x's and/or 0's and/or 1's to the inputs of the net,  

writes the result.  

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 20. The data sets follow.  

Each data set consists of two consecutive lines. The rst of those lines contains exactly two positive integers n and m separated by single space, 1 <= n <= 100 000, 1 <= m <= 200 000. Integer n is the number of the net inputs and integer m is the number of the gates in the net.  

The second of those lines contains exactly 2m nonzero integers, separated by single spaces. The numbers on positions 2j - 1 and 2j describe the signal sources for the inputs to gate j. The positive number s means the output of gate s. The negative number s means the (-s)-th input to the net. The gates and the net inputs are numbered starting from one. The input of each gate is connected to an input of the net or to an output of a gate whose description occurred earlier in the sequence. Each net input is connected to at least one gate input. Each gate output is connected to at least one gate input except the output of the last gate that is connected to the output of the net.

Output

The output should consist of exactly d lines, one line for each data set. The line number i should contain the answer to the i-th data set.  

The answer to one data set should consist of a sequence of exactly k characters terminated by the end of line (with no spaces in between). Each of those characters should be 0 (the digit 'zero' ) or 1 (the digit 'one') or x (lower-case letter 'x' ). The i-th symbol of the sequence denotes the assignment to the i-th input of the net.  

If there are more than one optimal assignment then your program should output any of them (but only one).

Sample Input

1
3 6
-1 -3 -1 -2 1 2 1 2 4 3 5 5

Sample Output

10x

Source


Regionals 2001 >> Europe - Central


问题链接POJ1435 ZOJ1390 UVA1607 UVALive2440 Gates

问题简述:(略)

问题分析

  二分搜索题,先占个位置,不解释。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ1435 ZOJ1390 UVA1607 UVALive2440 Gates */

#include <iostream>

using namespace std;

const int N = 2e6;
struct Gates
{
    int a, b, o;
} gates[N + 1];
int n, m;

int gnand(int k)
{
    for (int i = 1; i <= m; i++) {
        int a = gates[i].a;
        int b = gates[i].b;
        int va = (a < 0) ? -a > k : gates[a].o;
        int vb = (b < 0) ? -b > k : gates[b].o;
        gates[i].o = !(va && vb);
    }
    return gates[m].o;
}

int solve(int vn)
{
    int left = 1, right = n, mid;
    while(left < right) {
        mid = (right + left) / 2;
        if(gnand(mid) == vn)
            right = mid;
        else
            left = mid + 1;
    }
    return left;
}

int main()
{
    ios::sync_with_stdio(false);

    int t;
    cin >> t;
    while(t--) {
        cin >> n >> m;
        for(int i = 1; i <= m; i++)
            cin >> gates[i].a >> gates[i].b;
            int v0 = gnand(0);
            int vn = gnand(n);
            if(v0 == vn) {
                for(int i = 1; i <= n; i++)
                    cout << "0";
            } else {
                int x = solve(vn);
                for(int i = 1; i < x; i++)
                    cout << "0";
                cout << "x";
                for(int i = x + 1; i <= n; i++)
                    cout << "1";
            }
            cout << endl;
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值