POJ3614 Sunscreen【贪心】

55 篇文章 6 订阅
32 篇文章 3 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10348 Accepted: 3618

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPFrating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2

Source


问题链接POJ3614 Sunscreen

问题简述

  有C(1<=C<=2500)头奶牛晒太阳 ,每个奶牛有各自能够忍受阳光强度的最小值和最大值。奶牛需要涂抹防晒霜,防太阳光照射。阳光太大晒伤了,太小奶牛没感觉。

  给出了L(1<=L<=2500)种防晒霜,并且给出能抵御的阳光强度和数量(能涂抹几头牛)。

  求有几头奶牛能够享受晒太阳。

问题分析

  典型的贪心问题。  

  奶牛按照能够忍受阳光强度的最小值从小到大排序。防晒霜也按照能够抵御的阳光强度从小到大排序。然后,进行匹配,防晒霜按照能够抵御的阳光强度从小到大进行处理,符合奶牛的最小值小于或等于防晒霜的,将奶牛的最大值放入优先队列之中。然后优先队列按最大值的从小到大顺序出队。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ3614 Sunscreen */

#include <iostream>
#include <algorithm>
#include <queue>
#include <stdio.h>

using namespace std;

typedef pair<int, int> PAIR;
const int N = 2500;
PAIR cow[N], bottle[N];

int main()
{
    int c, l;
    priority_queue<int, vector<int>, greater<int> > q;

    scanf("%d%d", &c, &l);
    for(int i = 0; i < c; i++)
        scanf("%d%d", &cow[i].first, &cow[i].second);
    for(int i = 0; i < l; i++)
        scanf("%d%d", &bottle[i].first, &bottle[i].second);

    sort(cow, cow + c);
    sort(bottle, bottle + l);

    int ans = 0, k = 0;
    for(int i = 0; i < l; i++) {
        while(k < c && cow[k].first <= bottle[i].first)
            q.push(cow[k++].second);

        while(!q.empty() && bottle[i].second) {
            int a = q.top();
            q.pop();
            if(a < bottle[i].first)
                continue;
            ans++;
            bottle[i].second--;
        }
    }

    printf("%d\n", ans);

    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值