POJ1703 Find them, Catch them【并查集】

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50328 Accepted: 15453

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)  

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:  

1. D [a] [b]  
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.  

2. A [a] [b]  
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.  

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


问题链接POJ1703 Find them, Catch them

问题简述:(略)

问题分析

  这是一个用并查集来解的问题,略为不同于标准的并查集问题。  

  总共有n个人,每个人分为自身(1到n)和分身(n+1到2n)两个圈子,自身加入朋友圈,分身加入敌人圈。圈子或为龙帮或为蛇帮。

  然后根据不同的message做相应的操作即可。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ1703 Find them, Catch them */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 1e5;
int f[N + N + 1];
int n, m;

void Init()
{
    for (int i = 1; i <= n; i++) {
        f[i] = i;
        f[n + i] = n + i;
    }
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

int main()
{
    int t;

    scanf("%d", &t);
    while(t--) {
        scanf("%d%d%*c", &n, &m);

        Init();

        while(m--) {
            char message;
            int a, b;

            scanf("%c%d%d%*c", &message, &a, &b);
            if(message ==  'A') {
                int pa = Find(a);
                int pb = Find(b);
                int pbn = Find(n + b);
                if(pa != pb && pa != pbn)
                    printf("Not sure yet.\n");
                else if(pa == pb)
                    printf("In the same gang.\n");
                else
                    printf("In different gangs.\n");
            } else if(message ==  'D'){
                int pa = Find(a);
                int pbn = Find(n + b);
                if(pa != pbn) {
                    f[pa] = pbn;
                    f[Find(b)] = Find(n + a);
                }
            }
        }
    }

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值