A Simple Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5833 Accepted Submission(s): 3181
Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.
Example
For n = 24, o = 3 and p = 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.
Example
For n = 24, o = 3 and p = 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.
Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Output
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
Sample Input
1 24
Sample Output
3 3
Source
问题链接:HDU1339 ZOJ1382 A Simple Task
问题简述:
有d个测试用例,输入d个正整数n,求满足n = o*2^p(o为奇数,p为非负数)的o和p。
问题分析:
用暴力法求解,不断地做n除以2算出2的幂p,剩下的就是奇数o。
程序说明:(略)
题记:(略)
参考链接:(略)
/* HDU1339 ZOJ1382 A Simple Task */
#include <iostream>
using namespace std;
int main()
{
int d, n, p;
cin >> d;
while (d--) {
cin >> n;
p = 0;
while (n % 2 == 0) {
n /= 2;
p++;
}
cout << n << " " << p << endl;
}
return 0;
}