POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads【Kruskal算法+并查集】

509 篇文章 9 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30648 Accepted: 14347

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.  

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.  

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.  

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source


Regionals 2002 >> North America - Mid-Central USA


问题链接POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads

问题描述:(略)

问题分析

  这是一个最小生成树的为问题,解决的算法有Kruskal(克鲁斯卡尔)算法和Prim(普里姆) 算法。

程序说明

  本程序使用Kruskal算法实现。有关最小生成树的问题,使用克鲁斯卡尔算法更具有优势,只需要对所有的边进行排序后处理一遍即可。程序中使用了并查集,用来判定加入一条边后会不会产生循环。程序中,图采用边列表的方式存储,排序一下就好了。

  这个题的时间问题并不突出,用C++的输入输出也可以通过。


AC的C++语言程序如下:

/* POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 26;

int f[N + 1];

void UFInit(int n)
{
    for(int i = 1; i <=n; i++)
        f[i] = i;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

bool Union(int a, int b)
{
    a = Find(a);
    b = Find(b);
    if (a != b) {
        f[a] = b;
        return true;
    } else
        return false;
}

struct Edge {
    int u, v, w;
} edges[N * (N - 1)];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

int main()
{
    int n, m, d, cnt2;
    char start, end;
    while(cin >> n && n) {
        UFInit(N);

        cnt2 = 0;
        for(int i = 0; i < n - 1; i++) {
            cin >> start >> m;
            for(int j = 1; j <= m; j++) {
                cin >> end >> d;
                edges[cnt2].u = start - 'A' + 1;
                edges[cnt2].v = end - 'A' + 1;
                edges[cnt2++].w = d;
            }
        }

            // Kruscal算法
            int ans = 0;
            sort(edges, edges + cnt2, cmp);
            for(int i = 0; i < cnt2; i++)
                if(Union(edges[i].u, edges[i].v))
                    ans += edges[i].w;

            // 输出结果
            cout << ans << endl;
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值