POJ1056 HDU1305 ZOJ1808 UVA644 UVALive5479 Immediate Decodability【字典树】

708 篇文章 19 订阅
509 篇文章 9 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14371 Accepted: 6862

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.  

Examples: Assume an alphabet that has symbols {A, B, C, D}  

The following code is immediately decodable:  
A:01 B:10 C:0010 D:0000  

but this one is not:  
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)  

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Source


Regionals 1998 >> North America - Pacific Northwest


问题链接POJ1056 HDU1305 ZOJ1808 UVA644 UVALive5479 Immediate Decodability

问题描述

  输入若干0和1组成的字符串集合,字符串“9”为字符串输入结束,判断其中的某个字符串是否为另外一个字符串的前缀。

问题分析

  这个问题原理上来说,看似一个Huffman编码问题,也可以说是。

  该问题用构建字典树的方法来解决。构造一个二叉字典树进行判断即可。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ1056 HDU1305 ZOJ1808 UVA644 UVALive5479 Immediate Decodability */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 8;
const int LEN = 10;
const int SIZE = 2;
const char SCHAR = '0';

struct Tree {
    int acnt;   // access count
    int ccnt;   // child number
    int childs[SIZE];
    void init()
    {
        acnt = 1;
        ccnt = 0;
        memset(childs, 0, sizeof(childs));
    }
} trie[N * LEN];
int ncnt;   // Trie Node count
char s[LEN]; // Input

bool insert(char s[])
{
    int p = 0;
    for(int i = 0; s[i]; i++) {
        int k = s[i] - SCHAR;
        int child = trie[p].childs[k];
        if(child) {
            trie[child].acnt++;
            p = child;
        } else {
            if(i > 0 && trie[p].acnt > 1 && trie[p].ccnt == 0)
                return false;
            trie[++ncnt].init();
            trie[p].childs[k] = ncnt;
            trie[p].ccnt++;
            p = ncnt;
        }
    }
    return trie[p].ccnt == 0;
}

int query(char s[])
{
    int p = 0;
    for (int i = 0; s[i]; i++) {
        int k = s[i] - SCHAR;
        int child = trie[p].childs[k];
        if (child == 0)
            return 0;
        else
            p = child;
    }
    return trie[p].ccnt;
}

int main()
{
    int caseno = 0;
    bool flag = true;
    ncnt = 0;
    trie[ncnt].init();
    while(~scanf("%s", s)) {
        if(s[0] == '9') {
            if(flag)
                printf("Set %d is immediately decodable\n", ++caseno);
            else
                printf("Set %d is not immediately decodable\n", ++caseno);

            flag = true;
            ncnt = 0;
            trie[ncnt].init();
        } else {
            if(flag)
                if(!insert(s))
                    flag = false;
        }
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值