HDU1702 ACboy needs your help again!【模拟】

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12266 Accepted Submission(s): 6064

Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ?.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output
1
2
2
1
1
2
None
2
3

Source
2007省赛集训队练习赛(1)

问题链接HDU1702 ACboy needs your help again!
问题简述
    给出操作方式,FIFO(先进先出)或FILO(先进后出),模拟操作过程并输出结果。
问题分析
    根据操作方式,或用队列或用堆栈进行模拟。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU1702 ACboy needs your help again! */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t, n, a;
    char op[5];
    scanf("%d", &t);
    while(t--) {
        scanf("%d%s", &n, op);
        if(op[2] == 'F') {
            queue<int> q;
            for(int i = 1; i <= n; i++) {
                scanf("%s", op);
                if(op[0] == 'I') {
                    scanf("%d", &a);
                    q.push(a);
                } else
                    if(q.empty())
                        printf("None\n");
                    else {
                        printf("%d\n", q.front());
                        q.pop();
                    }
            }
        } else {
            stack<int> s;
            for(int i = 1; i <= n; i++) {
                scanf("%s", op);
                if(op[0] == 'I') {
                    scanf("%d", &a);
                    s.push(a);
                } else
                    if(s.empty())
                        printf("None\n");
                    else {
                        printf("%d\n", s.top());
                        s.pop();
                    }
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值