POJ1188 HDU1417 UVA737 UVALive5299 Gleaming the Cubes【立方体交集】

708 篇文章 18 订阅
509 篇文章 6 订阅

Gleaming the Cubes
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1461 Accepted: 782

Description

As chief engineer of the Starship Interprize, the task of repairing the hyperstellar, cubic, transwarped-out software has fallen on your shoulders. Simply put, you must compute the volume of the intersection of anywhere from 2 to 1000 cubes.

Input

The input consists of several sets of cubes for which the volume of their intersections must be computed. The first line of each set contains a number (from 2 to 1000) which indicates the number of cubes which follow, one cube per line. Each line which describes a cube contains four integers. The first three integers are the x, y, and z coordinates of the corner of a cube, and the fourth integer is the positive distance which the cube extends in each of the three directions (parallel to the x, y, and z axes) from that corner.

Following the data for the first set of cubes will be a number which indicates how many cubes are in a second set, followed by the cube descriptions for the second set, again one per line. Following this will be a third set, and so on.A number =0 indicate the end of input.

Output

Your program should process sets all of cubes, outputting the volume of their intersections to the output file, one set per line, until a zero is read for the number of cubes.

Sample Input

2
0 0 0 10
9 1 1 5
3
0 0 0 10
9 1 1 5
8 2 2 3
0

Sample Output

25
9

Source

Mid-Central USA 1993

Regionals 1993 >> North America - Mid-Central USA

问题链接POJ1188 HDU1417 UVA737 UVALive5299 Gleaming the Cubes
问题简述:(略)
问题分析
    计算立方体交集,模板题。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1188 HDU1417 UVA737 UVALive5299 Gleaming the Cubes */

#include <iostream>
#include <cstdio>

using namespace std;

struct Point {
    int x, y, z;
};

int main()
{
    Point a, b, c;
    int n, d;
    while(~scanf("%d", &n) && n) {
        scanf("%d %d %d %d", &a.x, &a.y, &a.z, &d);
        b.x = a.x + d;
        b.y = a.y + d;
        b.z = a.z + d;
        for(int i = 1; i < n; i++) {
            scanf("%d %d %d %d",&c.x, &c.y, &c.z, &d);
            a.x = max(c.x, a.x);
            a.y = max(c.y, a.y);
            a.z = max(c.z, a.z);
            b.x = min(c.x + d, b.x);
            b.y = min(c.y + d, b.y);
            b.z = min(c.z + d, b.z);
        }
        printf("%d\n", max((b.x - a.x) * (b.y - a.y) * (b.z - a.z), 0));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值