UVA10493 Cats, with or without Hats【组合】

A cat wears a hat if and only if it has N cats in its hat. There is exactly one cat that is not inside any other cat’s hat. If there are M cats without hats, how many cats are there?
Input
Input consists of several test cases. For each case, there would be two integers, N and M, where 1 ≤ N < 100000 and 1 ≤ M < 100000. The input ends with a case where N = 0. You must not process this test case.
Output
For each test case, print N and M. Then if the total number of cats can be expressible uniquely in an integer, print the number. If the case is impossible print the word ‘Impossible’ without quotes. If there are multiple answers, print the word ‘Multiple’ without the quotes.
Sample Input
2 5
3 4
3 3
0 0
Sample Output
2 5 9
3 4 Impossible
3 3 4

问题链接UVA10493 Cats, with or without Hats
问题简述:(略)
问题分析
    先占个位置。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10493 Cats, with or without Hats */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n, m;
    while(~scanf("%d %d",&n, &m) && (n || m)) {
        if(n == 1) {
            if(m == 1)
                printf("%d %d Multiple\n", n, m);
            else
                printf("%d %d Impossible\n", n, m);
        } else {
            if((m - n) % (n - 1) == 0)
                printf("%d %d %d\n", n, m, (n + 1) + n * ((m - n) / (n - 1)));
            else
                printf("%d %d Impossible\n", n, m);
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值