UVA465 Overflow【大数】

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a “normal” signed integer (type integer if you are working Pascal, type int if you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators ‘+’ or ‘*’, and another integer.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ‘first number too big’, ‘second number too big’, ‘result too big’.
Sample Input
300 + 3
9999999999999999999999 + 11
Sample Output
300 + 3
9999999999999999999999 + 11
first number too big
result too big

问题链接UVA465 Overflow
问题简述:(略)
问题分析
    看似大数计算问题,实际上并不需要算出大数的结果,只需要做个判断输出判断结果就可以了,所以就借用一下double类型的变量就可以了。
    C语言的头文件中有limits.h,其中有各种类型整数变量的最值。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA465 Overflow */

#include <bits/stdc++.h>

using namespace std;

const int N = 1000;
char s1[N + 1], s2[N + 2], op;

int main()
{
    double a, b;
    while(~scanf("%s %c %s", s1, &op, s2)) {
        a = atof(s1);
        b = atof(s2);

        printf("%s %c %s\n", s1, op, s2);
        if(a > INT_MAX)
            printf("first number too big\n");
        if(b > INT_MAX)
            printf("second number too big\n");
        if(op == '+' && a + b > INT_MAX)
             printf("result too big\n");
        else if(op == '*' && a * b > INT_MAX)
            printf("result too big\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值