UVA297 UVALive5598 Quadtrees【四叉树】

281 篇文章 4 订阅
17 篇文章 1 订阅

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.
    Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.
    A modern computer artist works with black-and-white images of 32 × 32 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.
    This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.
    In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.
在这里插入图片描述
Input
The first line of input specifies the number of test cases (N) your program has to process.
    The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter ‘p’ indicates a parent node, the letter ‘f’ (full) a black quadrant and the letter ‘e’ (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).
Output
For each test case, print on one line the text ‘There are X black pixels.’, where X is the number of black pixels in the resulting image.
Sample Input
3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe
Sample Output
There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.

Regionals 1994 >> Europe - Southwestern

问题链接UVA297 UVALive5598 Quadtrees
问题简述:(略)
问题分析
    用四分树来表示一个黑白图像,方法是用根结点表示整幅图像,然后把行列各分成两等分,按照图中的方式编号,从左到右对应4个子结点。如果某子结点对应的区域全白或全黑,则直接用一个黑结点或者白结点表示;如果既有黑又有白,则用一个灰结点表示,并且为这个区域递归建树。
    给出两棵四分树的先序遍历,求二者合并之后(黑色部分合并)黑色像素的个数。p表示中间结点,f表示黑色(full),e表示白色(empty)。每个图的大小都为32*32,输出黑色块的个数。。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA297 UVALive5598 Quadtrees */

#include <bits/stdc++.h>

const int LEN = 32;     // 2^5
const int N = 1024;      // 2^10
char s[N + 1];
int buf[LEN][LEN], cnt;

void draw(const char* s, int &p, int x, int y, int w)
{
    char ch = s[p++];
    if (ch == 'p') {
        draw(s, p, x, y+w/2, w/2);    // 1
        draw(s, p, x, y, w/2);        // 2
        draw(s, p, x+w/2, y, w/2);    // 3
        draw(s, p, x+w/2, y+w/2, w/2);// 4
    }
    else if (ch == 'f') {
        for (int i = x; i < x+w; i++)
            for (int j = y; j < y+w; j++)
                if (buf[i][j] == 0) buf[i][j] = 1, cnt++;
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--) {
        memset(buf, 0, sizeof(buf));

        cnt = 0;
        scanf("%s", s);
        int p = 0;
        draw(s, p, 0, 0, LEN);
        scanf("%s", s);
        p = 0;
        draw(s, p, 0, 0, LEN);

        printf("There are %d black pixels.\n", cnt);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值