POJ3359 UVA1209 LA3173 Wordfish【Ad Hoc】

509 篇文章 9 订阅
281 篇文章 4 订阅

Wordfish
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1082 Accepted: 535

Description

You have been tasked to infiltrate a tight-lipped society for fun and profit: the ACM ICPC regional judges. Through the PC2 “submission” software, you know that classified information is accessible through the log-ins of the judges tasked to a particular “regional site”. However, you are not certain that any particular judge has access to all the relevant information, so several log-ins will be required. You have been handed down a list of usernames, and the passwords used can be derived from these usernames, as follows:

Input

The input will only have capital letters (denoting the usernames) and carriage returns. Each line (thus each username) will not be longer than twenty characters, and there will not be more than 12 “judges” whose log-ins you will need to infiltrate. Strangely, no username uses any letter more than once.

Output

For each username, you must produce a line containing the password of length within 20 which that username uses. The password for a given username is determined from the twenty-one lexicographically consecutive permutations of the username, the eleventh (middle) of which is the username itself. For example, if the username is WORDFISH, the lexicographic permutations of WORDFISH contain, in order:

…, WOISHRFD, WOISRDFH, WOISRDHF, WOISRFDH, WOISRFHD, WOISRHDF, WOISRHFD, WORDFHIS, WORDFHSI, WORDFIHS, WORDFISH, WORDFSHI, WORDFSIH, WORDHFIS, WORDHFSI, WORDHIFS, WORDHISF, WORDHSFI, WORDHSIF, WORDIFHS, WORDIFSH, …

The password is then the permutation among the twenty-one lexicographically consecutive permutations of the username which has the largest minimum absolute distance between consecutive letters (and the first amongst the lexicographically ordered, if several permutations have the largest minimum absolute distance), followed by that minimum absolute distance. For the username WORDFISH, the password is WORDHSFI3.

Sample Input

WORDFISH

Sample Output

WORDHSFI3

Source

Manila 2006

Regionals 2006 >> Asia - Manila

问题链接POJ3359 UVA1209 LA3173 Wordfish
问题简述:(略)
问题分析
    虽然是一个简单题,还是用到了全排列函数,值得了解细节。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ3359 UVA1209 LA3173 Wordfish */

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <climits>

using namespace std;

int diff(string& s)
{
    int mind = INT_MAX;
    for(int i = 0; i < (int)s.size() - 1; i++)
        mind = min(mind, abs(s[i + 1] - s[i]));
    return mind;
}

bool cmp(pair<string, int> a, pair<string, int> b)
{
    return a.second == b.second ? a.first > b.first : a.second > b.second;
}

int main()
{
    string usr, usr2;
    while(cin >> usr) {
        vector<pair<string, int> > vp;

        usr2 = usr;
        for(int i = 1; i <= 10; i++) {
            prev_permutation(usr.begin(), usr.end());
            vp.push_back(make_pair(usr, diff(usr)));
        }
        vp.push_back(make_pair(usr2, diff(usr2)));
        for(int i = 1; i <= 10; i++) {
            next_permutation(usr2.begin(), usr2.end());
            vp.push_back(make_pair(usr2, diff(usr2)));
        }

        sort(vp.begin(), vp.end(), cmp);

        int d = vp[0].second;
        for(int i = 0; i < (int)vp.size(); i++) {
            if(vp[i].second < d) {
                printf("%s%d\n", vp[i - 1].first.c_str(), vp[i - 1].second);
                break;
            }
            if(d == 1) {
                printf("%s%d\n", vp[(int)vp.size() - 1].first.c_str(), vp[(int)vp.size() - 1].second);
                break;
            }
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值