UVA11679 Sub-prime【水题】

The most recent economic crisis was partly caused by the manner in which banks made loans to people unable to repay them and resold such loans to other banks as debentures. Obviously, when people failed to repay their loans, the whole system collapsed.
    The crisis was so deep that it affected countries all over the world, including Nlogonia, where the honored prime minister Man Dashuva ordered the Central Bank chairman to come up with a solution. He came up with a brilliant idea: if all banks could liquidate its debentures only with its own monetary reserves, all banks would survive and the crisis would be averted.
    However, with the elevated number of debentures and banks involved, this was an extremely complicated task, so he asked for your help in writing a program that, given the banks and the debentures printed by them, determines if it is possible that all banks pay back their debts using only their monetary reserves and credits.
Input
The input consists of several test cases. The first line of each test case contains two integers B and N, indicating the number of banks (1 ≤ B ≤ 20) and the number of debentures printed by the banks (1 ≤ N ≤ 20). The banks are identified by integers between 1 and B. The second line contains B integers Ri separated by spaces, indicating the monetary reserves of each one of the B banks (0 ≤ Ri ≤ 104, for 1 ≤ i ≤ B). The N following lines contain each one three integers separated by spaces: an integer D, indicating the debtor bank (1 ≤ D ≤ B), an integer C , indicating the creditor bank (1 ≤ C ≤ B and D <> C) and an integer V , indicating the debenture value (1 ≤ V ≤ 104).
    The end of input is indicated by a line containing only two zeros, separated by spaces.
Output
For each test case, your program should print a single line, containing a single character: ‘S’, if it is possible to liquidate all debentures without a bailout from the Central Bank of Nlogonia, or ‘N’ if a bailout is necessary.
Sample Input
3 3
1 1 1
1 2 1
2 3 2
3 1 3
3 3
1 1 1
1 2 1
2 3 2
3 1 4
3 3
1 1 1
1 2 2
2 3 2
3 1 2
0 0
Sample Output
S
N
S

问题链接UVA11679 Sub-prime
问题简述:(略)
问题分析
    一些银行中有储蓄,并且进行借贷,判定所有银行的储蓄是否都能支付借贷。
    简单题不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA11679 Sub-prime */

#include <bits/stdc++.h>

using namespace std;

const int N = 20;
int reserves[N + 1];

int main()
{
    int b, n;
    while (~scanf("%d%d", &b, &n) && (b || n)) {
        for (int i = 1; i <= b; i++)
            scanf("%d", &reserves[i]);
        for (int i = 1; i <= n; i++) {
            int d, c, v;
            scanf("%d%d%d", &d, &c, &v);
            reserves[d] -= v;
            reserves[c] += v;
        }

        bool flag = true;
        for (int i = 1; i <= b; i++) {
            if (reserves[i] < 0) {
                flag = false;
                break;
            }
        }

        puts(flag ? "S" : "N");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值