POJ1044 ZOJ1143 UVA700 LA5636 Date Bugs【水题】

509 篇文章 6 订阅
281 篇文章 4 订阅

Date bugs
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3358 Accepted: 1001

Description

There are rumors that there are a lot of computers having a problem with the year 2000. As they use only two digits to represent the year, the date will suddenly turn from 1999 to 1900. In fact, there are also many other, similar problems. On some systems, a 32-bit integer is used to store the number of seconds that have elapsed since a certain fixed date. In this
way, when 2^32 seconds (about 136 Years) have elapsed, the date will jump back to whatever the fixed date is.
Now, what can you do about all that mess? Imagine you have two computers C1 and C with two different bugs: One with the ordinary Y2K-Bug (i. e. switching to a1 := 1900 instead of b1 := 2000) and one switching to a2 := 1904 instead of b2 := 2040. Imagine that the C1 displays the year y1 := 1941 and C2 the year y2 := 2005. Then you know the following (assuming that there are no other bugs): the real year can’t be 1941, since, then, both computers would show the (same) right date. If the year would be 2005, y1 would be 1905, so this is impossible, too. Looking only at C1 , we know that the real year is one of the following: 1941, 2041, 2141, etc. We now can calculate what C2 would display in these years: 1941, 1905, 2005, etc. So in fact, it is possible that the actual year is 2141.
To calculate all this manually is a lot of work. (And you don’t really want to do it each time you forgot the actual year.) So, your task is to write a program which does the calculation for you: find the first possible real year, knowing what some other computers say (yi) and knowing their bugs (switching to ai instead of bi ). Note that the year ai is definitely not after the year the computer was built. Since the actual year can’t be before the year the computers were built, the year your program is looking for can’t be before any ai .

Input

The input file contains several test cases, in which the actual year has to be calculated. The description of each case starts with a line containing an integer n (1 <= n <= 20), the number of computers. Then, there is one line containing three integers yi,ai,bi for each computer (0 <= ai <= yi < bi < 10000). yi is the year the computer displays, bi is the year in which the bug happens (i. e. the first year which can’t be displayed by this computer) and ai is the year that the computer displays instead of bi .
The input is terminated by a test case with n = 0. It should not be processed.

Output

For each test case, output output the line “Case #k:”, where k is the number of the situation. Then, output the line “The actual year is z.”, where z is the smallest possible year (satisfying all computers and being greater or equal to u). If there is no such year less than 10000, output “Unkown bugs detected.”. Output a blank line after each case.

Sample Input

2
1941 1900 2000
2005 1904 2040
2
1998 1900 2000
1999 1900 2000
0

Sample Output

Case #1:
The actual year is 2141.

Case #2:
Unknown bugs detected.

Source

Mid-Central European Regional Contest 1999

Regionals 1999 >> Europe - Mid-Central
Regionals 1999 >> Europe - Southwestern

问题链接POJ1044 ZOJ1143 UVA700 LA5636 Date Bugs
问题简述:(略)
问题分析
    有一个日期BUG,给定日期a和b,当日期超过b时就从a开始算起。现在给定日期y、a和b分别代表按照错误算法的年份y,小年份a,最大年份b。求最小的可能的实际年份。
    水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1044 ZOJ1143 UVA700 LA5636 Date Bugs */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 10000;
int cnt[N];

int main()
{
    int n, y, a, b, caseno = 0;
    while(~scanf("%d", &n) && n) {
        memset(cnt, 0, sizeof(cnt));

        for(int i = 1; i <= n; i++) {
            scanf("%d%d%d", &y, &a, &b);

            for(int j = y; j < N; j += b - a)
                cnt[j]++;
        }

        bool flag = false;
        for(int i = 0; i < N; i++)
            if(cnt[i] == n) {
                printf("Case #%d:\nThe actual year is %d.\n\n", ++caseno, i);
                flag = true;
                break;
            }
        if(flag == false)
            printf("Case #%d:\nUnknown bugs detected.\n\n", ++caseno);
    }

    return 0;
}
  • 0
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值