利用二维数组搜索
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
for(int i=0; i<8; i++)
{
int dx = x+dir[i][0];
int dy = y+dir[i][1];
if(dx<0||dx>n-1||dy<0||dy>m-1||balabala...)
continue;
else
{
field[dx][dy] = balabala;
dfs(dx,dy);
}
}
}
POJ-2386 Lake Counting
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44446 Accepted: 21971
Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.
Input
- Line 1: Two space-separated integers: N and M
- Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
Output
- Line 1: The number of ponds in Farmer John’s field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n,m;
char field[128][128];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
for(int i=0; i<8; i++)
{
int dx = x+dir[i][0];
int dy = y+dir[i][1];
if(dx<0||dx>n-1||dy<0||dy>m-1||field[dx][dy]=='.')
continue;
else
{
field[dx][dy] = '.';
dfs(dx,dy);
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
int cnt = 0;
memset(field,0,sizeof(field));
for(int i=0; i<n; i++)
scanf("%s",field[i]);
for(int i=0; i<n; i++)
for(int j=0; j<m; j++)
{
if(field[i][j]=='W')
{
field[i][j] = '.';
cnt++;
dfs(i,j);
}
}
printf("%d\n",cnt);
}
return 0;
}
UVa-572 Oil Deposits
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n,m;
char field[128][128];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
for(int i=0; i<8; i++)
{
int dx = x+dir[i][0];
int dy = y+dir[i][1];
if(dx<0||dx>n-1||dy<0||dy>m-1||field[dx][dy]=='*')
continue;
else
{
field[dx][dy] = '*';
dfs(dx,dy);
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m),(n+m))
{
int cnt = 0;
memset(field,0,sizeof(field));
for(int i=0; i<n; i++)
scanf("%s",field[i]);
for(int i=0; i<n; i++)
for(int j=0; j<m; j++)
{
if(field[i][j]=='@')
{
field[i][j] = '*';
cnt++;
dfs(i,j);
}
}
printf("%d\n",cnt);
}
return 0;
}