搜索入门:POJ 2386 Lake Counting& UVa 572 Oil Deposits(DFS模板)

利用二维数组搜索

int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
    for(int i=0; i<8; i++)
    {
        int dx = x+dir[i][0];
        int dy = y+dir[i][1];
        if(dx<0||dx>n-1||dy<0||dy>m-1||balabala...)
            continue;
        else
        {
            field[dx][dy] = balabala;
            dfs(dx,dy);
        }
    }
}

POJ-2386 Lake Counting

传送门

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44446 Accepted: 21971
Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output
  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12

W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n,m;
char field[128][128];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
    for(int i=0; i<8; i++)
    {
        int dx = x+dir[i][0];
        int dy = y+dir[i][1];
        if(dx<0||dx>n-1||dy<0||dy>m-1||field[dx][dy]=='.')
            continue;
        else
        {
            field[dx][dy] = '.';
            dfs(dx,dy);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int cnt = 0;
        memset(field,0,sizeof(field));
        for(int i=0; i<n; i++)
            scanf("%s",field[i]);
            for(int i=0; i<n; i++)
                for(int j=0; j<m; j++)
                {
                    if(field[i][j]=='W')
                    {
                        field[i][j] = '.';
                        cnt++;
                        dfs(i,j);
                    }
                }

        printf("%d\n",cnt);
    }
    return 0;
}

UVa-572 Oil Deposits

传送门

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n,m;
char field[128][128];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
void dfs(int x,int y)
{
    for(int i=0; i<8; i++)
    {
        int dx = x+dir[i][0];
        int dy = y+dir[i][1];
        if(dx<0||dx>n-1||dy<0||dy>m-1||field[dx][dy]=='*')
            continue;
        else
        {
            field[dx][dy] = '*';
            dfs(dx,dy);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m),(n+m))
    {
        int cnt = 0;
        memset(field,0,sizeof(field));
        for(int i=0; i<n; i++)
            scanf("%s",field[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(field[i][j]=='@')
                {
                    field[i][j] = '*';
                    cnt++;
                    dfs(i,j);
                }
            }
        printf("%d\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值