PAT 1028 List Sorting [排序]

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

-------------------------------我是题目和代码的分割线-------------------------------

#include<cstdio>
#include<algorithm>
#include<string.h>

using namespace std;

struct student
{
	char id[7],sname[8];
	int grade;
}stu[100005];

bool cmp1(student a,student b)
{
	return strcmp(a.id,b.id)<0;
}

//注意一下字符类型不能直接比大小 用strcmp 
bool cmp2(student a,student b)
{
	if(strcmp(a.sname,b.sname)!=0) return strcmp(a.sname,b.sname)<0;
	return strcmp(a.id,b.id)<0;
}

bool cmp3(student a,student b)
{
	if(a.grade!=b.grade) return a.grade<b.grade;
	return strcmp(a.id,b.id)<0;
}

int main()
{
	int n,c,i;
	scanf("%d%d",&n,&c);
	for(i=0;i<n;i++)
		scanf("%s%s%d",stu[i].id,stu[i].sname,&stu[i].grade);
	if(c==1) sort(stu,stu+n,cmp1);
	if(c==2) sort(stu,stu+n,cmp2);
	if(c==3) sort(stu,stu+n,cmp3);
	for(i=0;i<n;i++)
		printf("%s %s %d\n",stu[i].id,stu[i].sname,stu[i].grade);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
在Java中,可以使用Collections类的sort()方法来对List进行排序。这个方法使用了默认的排序顺序,也就是说,如果List中的元素是基本数据类型或实现了Comparable接口的对象,那么它们将按照升序排列。下面是一个示例: ```java import java.util.ArrayList; import java.util.Collections; import java.util.List; public class ListSortingExample { public static void main(String[] args) { List<Integer> numbers = new ArrayList<>(); numbers.add(5); numbers.add(2); numbers.add(10); numbers.add(1); System.out.println("Before sorting: " + numbers); Collections.sort(numbers); System.out.println("After sorting: " + numbers); } } ``` 输出结果为: ``` Before sorting: [5, 2, 10, 1] After sorting: [1, 2, 5, 10] ``` 如果你想按照其他特定的排序顺序进行排序,可以使用Comparator接口来实现自定义的比较器。你可以在sort()方法中传入一个Comparator对象来指定排序规则。以下是一个使用Comparator进行自定义排序的示例: ```java import java.util.ArrayList; import java.util.Collections; import java.util.Comparator; import java.util.List; public class ListSortingExample { public static void main(String[] args) { List<String> names = new ArrayList<>(); names.add("John"); names.add("Alice"); names.add("Bob"); names.add("Charlie"); System.out.println("Before sorting: " + names); Collections.sort(names, new Comparator<String>() { @Override public int compare(String name1, String name2) { return name1.compareTo(name2); } }); System.out.println("After sorting: " + names); } } ``` 输出结果为: ``` Before sorting: [John, Alice, Bob, Charlie] After sorting: [Alice, Bob, Charlie, John] ``` 在这个示例中,我们使用了匿名内部类来创建一个Comparator对象,并在compare()方法中实现了自定义的排序规则。这里我们使用了String的compareTo()方法来进行比较,以实现按字母顺序排序

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值