Six Degrees of Cowvin Bacon POJ - 2139

题目:

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 

题意:

如果两头牛在一起拍过电影,那么这两头牛就互相认识,距离是1,如果两头牛之间没有拍过电影,但是同时和第三者拍过电影,那么这两头牛还是认识,距离是2;每一头牛会有一个认识度:认识的所有的牛到这头牛的距离之和 / 认识的牛的数量;

记得把结果扩大100倍;

思路:

这题的本质就是最短路,可以直接进行计算;

因为数据的范围不大,所以可以直接用Floyd-Warshall算法;

只要记得结果要扩大100倍;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int inf=99999999;
const int N=10010;

int map[N][N];//存储城市之间的距离;
int n,m,q;
int aa,bb,cc;
int a[N];

void init()//初始化;
{
    for(int i=1; i<=n; i++)
    {
        for(int  0.0j=1; j<=n; j++)
        {
            if(i==j)
                map[i][j]=0;
            else
                map[i][j]=inf;
        }
    }
}

void qq(int x)//输入的时候初始化;
{
    int ii,jj;
    for(int i=0; i<x-1; i++)
    {
        for(int j=i+1; j<x; j++)
        {
            ii=a[i];
            jj=a[j];
            map[ii][jj]=map[jj][ii]=1;//无向图;
        }
    }
    return ;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d",&q);
            for(int j=0; j<q; j++)
                scanf("%d",&a[j]);
            qq(q);
        }
        //Floyd-Warshall算法;
        for(int k=1; k<=n; k++) //中转点;
        {
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=n; j++)
                {
                    if(map[i][j]>map[i][k]+map[k][j])
                        map[i][j]=map[i][k]+map[k][j];
                }
            }
        }
        int minn=N,pp;
        for(int i=1; i<=n; i++)
        {
            int sum=0,s=0;
            for(int j=1; j<=n; j++)
            {
                if(map[i][j]!=inf)
                {
                    sum++;
                    s+=map[i][j];
                }
            }
            sum--;
            pp=s*100/sum;//记得扩大100倍;
            minn=min(minn,pp);
        }
        printf("%d\n",minn);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值