A - Minimum Transport Cost

题目:

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:

给你一个N代表有N个城市,下面有一个N*N的矩阵,map【i】【j】代表i和j之间有一条要花费map【i】【j】的路,如果map【i】【j】==-1,城市i和j之间没有路,最后一行有N个数字,代表到每个城市要交的税。

思路:

但是不同简单的最短路问题,这道题要记录路径,记录路径我不太熟,看了大神的代码,用road【i】【j】,i代表来的位置,j代表去的位置,这样就可以完美的解决路径记录的问题了。

还有一点,这道题要求花费一样的路径要输出最小的路径,所以在判断最短路的时候我们还要判断是否是按照字典序排列。

当然要求的输出格式还是要注意的,尤其是每个测试数据后要输出一行空格,千万不能忘记。

代码如下:

#include<stdio.h>
#include<string.h>
#define N 1001
#define inf 99999999

int n;
int map[N][N];//地图;
int a,b;
int road[N][N];//路径;
int dis[N][N];//花费;
int cost[N];//每个城市要交的税收;

void Floyd()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(dis[i][j]>dis[i][k]+dis[k][j]+cost[k])
                {
                    dis[i][j]=dis[i][k]+dis[k][j]+cost[k];
                    road[i][j]=road[i][k];//记录路径;
                }//原来是i到j,现在是i到k;
                else if(dis[i][j]==dis[i][k]+dis[k][j]+cost[k])//判断字典序;
                {
                    if(road[i][j]>road[i][k])
                    {
                        road[i][j]=road[i][k];
                    }
                }
            }
        }
    }
    return ;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        int i,j;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==-1)//注意;
                    map[i][j]=inf;
                dis[i][j]=map[i][j];//存储花费;
                road[i][j]=j;//到哪个城市就存储哪个城市的编号;
            }
        }
        for(i=1;i<=n;i++)
            scanf("%d",&cost[i]);
        Floyd();
        while(~scanf("%d%d",&a,&b))
        {
            if(a==-1&&b==-1)
                break;
            printf("From %d to %d :\n",a,b);
            printf("Path: %d",a);
            for(i=a;i!=b;i=road[i][b])
            {
                printf("-->%d",road[i][b]);
            }
            printf("\n");
            printf("Total cost : %d\n",dis[a][b]);
            printf("\n");//注意格式;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值